Nonstop Email Notifs

Lately, my email inbox has been exploding with emails of replies to a watched thread I’m involved in. I try to check the settings to turn off whatever’s been sending these, but I can’t find anything where I can disable email notifications.

Are you on mobile, or a desktop browser? I know on a desktop browser, you can click your profile picture on the top right of the screen, click the little cog at the rightmost of the bar which appears, and then scroll down about halfway. There’s a way to turn off email notifications from there:


On mobile.
There’s a thing to turn off email notifications, but I only turned on “email me if someone mentions me”

No one mentions me on the thread and I still get emails.

Do you watch other threads?

Which thread is it? Is this a private message thread or one of the public ones you’re having issues with?

I have all email notifications turned off so I’m not completely sure.

I think if you’re watching a topic, instead of just tracking it, it might potentially email you every time anyone makes a post there?

Whereas if you’re just tracking it only emails you if they mention you or reply to you.


I think this is sometimes influenced by how users react to things. i.e. If you made a particularly noteworthy post, sometimes you’ll get spammed a bit as everyone replies specifically to you rather than the thread in general.

Also, if it’s just from certain threads, check whether you’re ‘watching’, ‘tracking’ or ‘normal’ at the bottom of the thread. ‘Watching’ means you’ll get notified for every single post on a conversation. Not what you want.

1 Like

Yeah just regular threads like Children of the Gods in WIP. Like you said it’s probably from “watching” rather than “tracking”. I’ll change those threads and see if it works.

1 Like