Need help with some small issues


#1

Hi…so in my game I created a opposed pair of Confederate and Union and set Union at 100…what I can’t seem to do later on is change that…I tried


*choice
    #Long Live the Confederacy!
        *page_break
        *set Union -25
        *goto confederacy
        
    #The Union Shall Prevail!
        *page_break
        *set Union -25
        *goto Union

Also, for fun I took a jpg picture off of the internet and put it into my games folder while adding the code for it. However when I go to that spot where the picture should be, it only shows a tiny black box with a question mark in it…

Thank you!


#2

Opposed_pair works the same as percent, you can’t ever set it to 0 or 100, it’s 1-99. And you’ll be using %+ and %- when you’re increasing/decreasing them. For opposed_pair you ought to be starting at 50. Actually that’s a simplified explanation, but go for that for now.

As for the jpg, I have no idea. Pictures go in the mygame folder.

Edit: Also, in your example, both choices decreases union.


#3

If you do want to have a number variable that goes from 0-100, you’ll need to set up a subroutine, using either *gosub or *gosub_scene, in the latter you’ll need to create a text file for it.

Something like this;



*set union +25
*gosub cap_stats


*label cap_stats

*if (union > 100)
   *set union 100
*if (union < 0)
   *set union 0

*return

This does work with percent and opposed_pair as far as I know, unless some update broke it.


#4

Best not to capitalize your variables – keep it all lower case. And you don’t need to follow a choice with a page_break, that happens naturally.

And like MutonElite said in his first response, the dynamics of opposed pair stats is designed for fairmath, which means no 0 or 100 – start with union at 99 if you want to begin the game with maximum union as the default, and write all stat changes with a % in front of them e.g. *set union %+10 or *set union %-50.


#5

Thank you for the help @Havenstone and @MutonElite I set Union to 99 and Confederacy to 1 and it worked with me doing *set Confederacy +blah blah instead…

I also got the pictures to work by placing them again in the mygame folder…I think I was placing them in the wrong spot before…

Thanks again!