My music worked and then stopped


#1

So I was bout to release the first chapter of my demo when I realized my music no longer played. A year or so ago I decided to add music, and read up on using other people’s music in a non profit way. I got it all shorted out and was able to use the Wither 3 Ardskellig music.

At first it work perfectly, and played when I wanted it to. Recently I had to remake all the files, and I put everything back the way it was. But now it doesn’t play at all, no matter what I do.

My images were working so I tried placing the file there, but to no avail. I tried re downloading it, and still it refused to work. Here’s what my files look like.

This is the code

*sound music/ardskellig.mp3
*image images/title.png
Music belongs to CD ProjektRed 

It’s th exact same as before but now it doesn’t work.

Any idea why?


Html images not working
#2

Hm. Make sure that the filename matches exactly between the actual name and the code.

On the other hand, can you play the music directly with your phone?


#3

Yes it plays perfectly fine.

Should I try changing it to mp4?


#4

Well, if the music’s name is “ardskellig.mp4,” then yes.
The extension should match, too.

BTW, isn’t it .m4a?


#5

It’s not .mp4 but I was hoping that changing both would make it work but to no avail. And .m4a? I’m not familiar with that


#6

Well, .mp4 is usually a video, while .m4a is what you get if you separate the audio from the video.

Perhaps, can I see the screenshot of the song’s filename? I’m curious.


#7

Sure, here ya go.


#8

Hmmmmenyemmnenyemm…

Just to clarify, did you tried to make the song works on dashingdon.com site or on your phone locally?


#9

I haven’t uploaded it at dashingdon yet, as I can’t compile the html on my phone. I rezipped the file, emailed it to myself, and then unzipped it and ran through a test play just to make sure it was intact. When it didn’t play in my pc, I tried on my phone and it hadn’t worked since.

I even redownloaded the launcher, and shared all the files locally, and it was still unhappy.


#10

Oh, I see.
Inside your zip file, try to put not only the .html, but also the image and the song files.

The directories should be like this

…/zipped folder/
…/zipped folder/images/
…/zipped folder/music/

Your .html should be in the “parent directory.”
Every folder contains their respective song and image file.

This means that whenever you extract your .zip, you get all the .html, the images folder, and the music folder in a single main directory.

TL;DR put your music folders (and the images too) alongside the .html


#11

I’m probably just tired, but I don’t understand what you mean. My music and images are inside the zip file to begin with. It’s hard to explain? I didn’t zip them individually if that’s what you mean.

I’ll figure it out I guess. It’s a little disappointing though, as I really enjoyed the music additions e.e.


#12

Eh?
Hmm… let me see.


Oh, I tried it. I think I’ve found the problem.

Try not to put your music in any folder.
Put it alongside the .html file, and edit the code to reflect that.


Oh wait. No!
Lul.

You used slash “/” in your code. Change that to backslash “\”.


#13

It works now, but when I compile it, none of my images or the music work. I’m such a mess.


#14

How would I venture to fix that?


#16

It seems like there is still no way to have images/music work in a compiled file? I tried the method that @CJW talked about, but it gave me so much shit I gave up. Isn’t there a simpler way? Or am I doomed to never have images? The last discussion of this was in like 2015 so…


#17

Could you expand on this? What exactly wasn’t working for you?


#19

Are the images in the same folder as the html file?


#20

I actually took a break cause’ I knew I was just pissed and probably missed it. So my bad. I got it to work on CSIDE finally, and I compiled it.

Alas my life can’t be easy. Everytime I upload it to dashingdon I get this.

I know its an html becuase it says so right here.

:woman_shrugging:t2:


#21

Don’t put audio/image files into folders. They should be directly in the mygame folder.


#22

Yeah I figured that out. Thanks e.e . But now dashindon decided to not like my HTML.

What can you do though, when you have luck like mine.