*sound doesn't work

I’m having trouble with getting the sound to work, is it
*sound decay.mp3 or *sound music/decay.mp3?

1 Like

Depending on the location, the parent directory is the one where index.html is located. In that sense, your chapters/scenes should be located in .../scenes

It should be *sound filename.format, with the file in the mygame folder iirc.

Though iirc sound can mess with screenreader and might make the game unnecessary large depending on the format

I already uploaded the sound file to my game, yet when I try to listen to it the *sound still doesn’t work (I’m on Chrome by the way)

Oh, upload to dashingdon?
Did you used *sound decay or *sound /music/decay?

I think the former is correct.

I tried both of the commands, they didn’t work

Silly question: where in the file is the command? In relation to the last choice/page_break?

*label tea_ceremony
*sound decay
As you enter the corridor that seems to loom before you, you had to duck because of all of the foliage and random brown ivy vines that seem to be decorating the very interior of the vast room```

You sure it’s just *sound decay?
You need to put the full filename; complete with the extension and capitalization.

1 Like

An offtopic request: please, present an option to turn sound off from the get go. This is not to bash on your vision of the game, but a simple convenience feature. I know I’d be grateful to have it in a text game.

*create audio 0

This game features music. Do you want to play it?
*choice
	#Yes
		*set audio true
	#No
		*set audio false

Then

*if (audio)
	*sound sample.mp3

Good luck!

2 Likes

I already put the extension and captialisation as *sound Decay.mp3 without any indentation, but the sound still doesn’t play…

Hmm, I’m getting itchy.

Try making sure that the sound can be played with your normal media player and reupload it again.

I already tried playing Decay.mp3 sound file with Windows Media Player and it works fine on there. And I reuploaded it more than once on Dashingdon. Plus when I try to go to the scene with that file on Google Chrome, I hear complete silence

That’s weird. I can get mine to work just fine.

Just curious, but do you put the command at the top of your scene? No *page_break preceding it?

This is my test in case you want to take a peek.

1 Like

I can’t hear anything from your test- and this is how I labeled the *sound in my game:

*label tea_ceremony
*sound /music/Decay.mp3
As you enter the corridor that seems to loom before you, you had to duck because of all of the foliage and random brown ivy vines that seem to be decorating the very interior of the vast room. Puzzled, you take time to inspect a nearby vine that dangles from an archway, which instantly blooms to your own intrigue.```

Well, that turns out even more weird, but I think I can narrow down the root.
Is there little horn :mega: icon at the tab?
dis

There is no horn icon at my Chrome tab.

nyobak

Uhh… now I’m not sure what is the cause. Definitely not from Dashingdon.com itself, as I can test it at my end, here. I hate to give up, but I honestly can’t figure out what can be the solution to this.

By the way, no need to put any filepath/address on your *sound command if you’re on dashingdon.


Edit: Maybe try updating the Chrome?
Done by going to Help > About Google Chrome in the hamburger menu. It should try to self-update. My Chrome version is 72.0.3626.119.

Google Chrome is up to date

Version 72.0.3626.119 (Official Build) (64-bit)

Does this tab icon appear on other sites, like youtube?

Also check chrome://settings/content/sound to see if sound is disabled.

1 Like