Multireplace "invalid @{} variable substitution"


#1

I’m having trouble with multireplace.

The error I’m getting is: “Error: court line 68: invalid @{} variable substitution at letter 1”

My code looks like this:

It is
@{palace_grandeur a squat room held up by thick columns | a fair hall of great columns | an airy hall with great columns | a large hall with great columns |
an incredible engineering achievement, as ceiling is supported by thin columns | easy to see why travelers think Ured was built by giants, for your
massive throneroom’s arched ceilings are supported by almost impossibly thin columns | easy to see why travelers think Ured was built by giants, for your
colossal throneroom is a truly-awe inspiring sight, a wonder of the world fit to seat the most honored of gods. Its columns }

The variable “palace_grandeur” is established in startup as

*create palace_grandeur 1

And altered in lines from the earlier part of the scene (potentially increased.) There’s no way that it would drop below 1 or rise above the maximum number of options.


#2

Try to add this in somewhere just to test if other stuff is working (then take it out later):

*temp test ""
*set test "@{palace_grandeur 1|2|3|4|5|6|7|8|9|10}"

palace_grandeur = ${test}

#3

I don’t think you can add line break/enter inside multireplace.


#4

Thanks for the test.
That part indeed functioned just fine.

Oh. So you’re saying that it all has to be one very long line of code? That’s cumbersome.


#5

Well, you can always use *if for long paragraphs. There’s no much difference, and it’s also looks more tidier ¯\_(ツ)_/¯


Or you can endure the pain

Summary

A young, ${appearance} of teenage years with a ${skin_col} colored skin. @{(transmorphed = 4) Facial features include ${eye_col}|A transmorphed, with ${eye_col}} eyes and @{hair_l bald head, claimed that ${pc_he} can't grow ${pc_hisl} hair.|bald hair on registration date. Claimed that ${baldlol}, and the hair is of a ${hair_col} color and|||||} @{(hair_t + 1) |||Straight|Wavy|curly}@{(hair_l = 2) type when not bald.|,} @{hair_l ||very-short hair.|short hair.|fairly long hair.|fairly long hair.|long hair.}
And deal with it :smiling_imp:


It’s one of my single line-code in my WiP.


#6

You can add *line_breaks by typing in [n/]! I’m doing that in my WIP, actually.


#7

Ah, yes. [n/] is an exception.


#8

That worked. Thanks @Szaal for identifying the root of the problem.