Journey to the throne(Wip) Updated 11 April

low-fantasy
gender-choice
#69

thank you for adding the new unit just finished reading the new update love it keep up the good work :slight_smile:

1 Like

#70

Just read the new update.

I enjoyed the skill selection (and I’m glad to see my suggestion of the parentheses in the code worked!) – it helps develop the main character and helps to begin introducing us to the other characters. A minor thing that might be nice is when we talk to the characters that taught us they give a small line depending on our stats. So, for example, when we speak to Lord Gerrad about the book and our knowledge is high, he might say that we probably remember all this information from our lessons – but if our knowledge is low, he might say he’s glad we’ve finally started to be interested in books.

I also liked the added reaction options when talking to the father. I think it really helps convey what sort of relationship the father has with his children, especially if you choose to argue – on one hand, he has to be the authoritative lord, but on the other hand, he tries to be even-handed and suggests taking his daughter on the next expedition.

Looking forward to reading more. :relaxed:

1 Like

#71

Hey,

Thanks for reading and glad you liked argue scene.
About the thing you said about adding line when we talk with other characters I agree with it and you will definitely see it in next update.

Thanks for your detailed reply it really helps.

1 Like

#72

Hey bro,

Thanks for reading and I am really glad you liked the new unit. It was your suggestion and I am glad it met with your standards.

1 Like

#73

I like this

1 Like

#74

I tried to ask “What is the count on our treasury?” and it gave me an error message:
prologue line 1486: increasing indent not allowed, expected 1 was 2

I suggest you to use CSIDE program. It has, among others, built-in “Test project” option, which allows you to run Quicktest and Randomtest. That will allow you to catch these “non-existent variable” and “encreasing intent not allowed” bugs easily before posting new game files.

Good luck with your game!

1 Like

#75

Thanks for your reply and reading the story.

About the treasury, I didn’t show it in stats till now but I will show it in future updates because I haven’t
calculated units cost per soldiers and many other things but I can give you a little estimation.
like If you have an army unit as a specialty of Haven then you will lose gold from Haven’s treasury and if you have farming as specialty you will have more food than normal count and little more gold but less no. of soldiers and something same for blacksmiths and traders.

About that error can you please send me a pic of it because last time I checked with a quicktest then
it was showing no error, I must have pressed backspace or space somewhere although I uploaded the file again after a quick test so there should not be a problem anymore.

Also Thanks for the “CSIDE” I will check on it right now.

1 Like

#76

Interesting, I don’t get this error now.

1 Like

#77

Na… It’s all cool now and really thanks for your reply.

1 Like

#78

While choosing the family banner:
If i choose a hammer, it lets me choose its color, then color in background.
If I choose a small plant, it goes directly to the background color selection, with this text: “Your family banner contain a sigil of plant in color with…”.

1 Like

#79

Ok I will correct it immediately.

Fixed it and Thank you for your time and help.

1 Like

#80

Not a complaint, but the sentence about character appearance looks like this in the beginning (before choosing eye and hair color): You have eyes, hair and you keep them and wear them. It conjured up an image in my head: a cloaked figure who keeps eyes in a box and wears hair as a necklace :slightly_smiling_face:

1 Like

#81

:smile: Yeah you are right It really looks odd and I will definitely fix it in next update.

1 Like

#82

1 Like

#83

I love the update, especially when you are able to choose what classes you excelled at.
Keep up the the good work!

1 Like

#84

I don’t know from where this error is coming, I have looked into the file, everything seems correct there and checked with a quicktest too.
But thanks for your reply man I will look into it and will do some alteration with code.

0 Likes

#85

The error from my earlier comment is back again. I played the game several times. When I play normally, I get the error, but when I choose the 1st answer in every choice to get to that part where the error happened earlier, it doesn’t. :thinking:
After trying several more times, I came to the conclusion that the error most likely depends on the main occupation of your city: asking about the treasury count in a farmer or merchant city gives you a normal answer, but the blacksmith town gets a “prologue line 1486: increasing indent not allowed, expected 1 was 2” error, instead of “Haven is the town of blacksmiths, we have so and so gold coins”.
I hope that helps.

2 Likes

#86

Ok fixed it now. Thanks @Kotosinica and @Jaden_Hairston_Reid for your replies

2 Likes

#87

i really like this story…
keep up the good work
i look foward to reading more

1 Like

#88

Is there anyway way u can add a save system in the game

0 Likes