Issues with having title images show

So i am having trouble getting my title/header image thing to actual show in the game. I put in the code it says on the wiki and upload it to dashingdon and then when i get to where it should be I just see the tiny broken picture thing. Im really not sure what to do.

First thing to check is the name of the image in the code. Usually you need to include .png/.jpg (or whatever kind of file it is) in the image name (i.e. *image image_name.png

This might not fix your problem, but it is the “have you tried turning it off and back on again?” for choicescript *image problems!

It didnt work should i have *image as one of the commands?

That is the command, yes. Wherever you want your image to appear in the game, you need to code it with the following format: *image image_name.png

I mean like in my startup where all the stats and stuff are. That is the code im using *image prologuepic.png but im getting nothing

I’m not quite sure what your question is here. Are you asking does this command need to go with the *create commands in startup.txt? If so, the answer is no. If not, I’m not sure what you mean

Yeah that was my question. Im just getting a little frustrated since i cant figure out what im doing wrong

1 Like

I understand your frustration and have experienced the same. My only last ditch piece of advice is to make sure that the image name you use in the code matches up exactly with the name of the image in your folder/on dashingdon (including the .png).

Come to think of it, a really dumb mistake I have made is putting my images in the wrong folder. It should be in the “mygame” folder (rather than the “scenes” folder, which is where I put it). It took my a good bit to figure that one out since it was so obvious. Of course, if you’re seeing this error on dashingdon, that isn’t the issue since you upload images straight to the site.

If neither of these things helps, then hopefully someone else will be able to put in their two cents! I’ll definitely be watching :worried:

Im not sure but this also might be the issue. a couple months ago my laptop died and i got a new one. Before it completely went dead on me i sent myself the documents with the first two chapters, stats, prologue and setup. COuld it possibly be because of that? Do i need to redownload the deafult file and just copy and paste my stuff there?

Was the *image command working in the original? If so, my suspicion would be that when you recreated everything, you renamed the image and forgot/didn’t notice. The original files themselves won’t automatically be better. It’s what’s in the files (the code) that matters

I actually didnt have any images in the original, this is my first time trying to incorporate them. The documents actually were just now put in a file together. Before hand they were just in downloads

It may have to do with the size of the image file. IIRC, dashingdon puts a limit on that. But I’m not sure if your problem was caused by this.

Edit: Did the image ever worked before?

1 Like

What should the size be? The wiki didnt specify currently i think its like 800x500


ETA: although it says per txt file here, this is from under the image upload section, so…? Not sure how to interpret. It may be a typo on dashingdon or completely irrelevant to images? Not sure

More edits:
For greater reference–


Wow I am seriously an idiot. This happened when I couldnt figure out save slots too. Thank you so much for the help

1 Like

Happy to help! But just to clear things up, was it the image size that was the problem after all?

No I didnt realize i had to upload the actual images on that thing you just sent a picture of…I thought it was meant for game covers…

1 Like

This topic was automatically closed 24 hours after the last reply. If you want to reopen your WiP, contact the moderators.