Header image not showing up?

Hello, I’m trying to create and add a header image to my chapters but the image is just a ‘white square’ when I try to playtest:

And the line of code I use for this is:

*image images/NHeader.jpg center

Any help is greatly appreciated. Thank you!

If this is in CSIDE, then images won’t load unless you import them as a scene.

Well that worked, thank you.

But what about on Dashingdon? Does it have to be the same there?

No, on Dashingdon it works the way you have it written. You only have to import images as a scene in CSIDE. :slight_smile:

Huh? Sorry, I’m a still little confused. I had used the code above for dashngdon, but the image still wasn’t showing up:

CSIDE made me do something different in order for the image to show up there, but when I tried the other code I still got that same error.

This was a screenshot of the 2 different code:

I also tried those side by side:

And only the gosub code worked. I would rather use the usual *image bc the gosub takes really long to load.

Sorry about this, and thank you for helping me :sweat_smile:

Update! I got the DashingDon part to work! I just had to remove the images/ extension! Sorry about that, and thank you so much for the help :relaxed:!

1 Like

I don’t know where this myth originated (I’ve seen it a few times now), but it’s not even remotely true. The image command should work exactly as-intended:

Most likely your path is wrong. Are you sure the extension is .jpg and not .jpeg?

Importing images as scenes is only recommended as a convenience method for redistributing your game.


I… had no idea that was possible. I guess I need to look at my image paths. :joy:

To be fair, CSIDE should be trying to diagnose incorrect paths for you. I’ve raised an enhancement request: https://github.com/ChoicescriptIDE/main/issues/97


It was just showing the images as the blank image icon. Technically I knew they weren’t working; I just thought it was because of the command I was using. :sweat: