If command not displaying text


#1

Hello people!
I’ve encountered a problem yet again. :laughing:

I’m having issues with the *if command. It doesn’t display the text I want it to. Instead, it jumps to another scene and just goes from there (I’ve double checked the *goto commands.)

There’s no error box that pops up when I run the game, I just notice that it skips past paragraphs.

This is the part that goes wrong:

*hide_reuse #Get a few hours of rest.
	*if (Auline < 30)
		Blah blah.
		*page_break 
		*goto morning_duties

	*if (Auline > 40)
		blah blah
		*page_break 
		*goto morning_duties

I’ve read though the wiki page multiple times but I can’t find the error. What am I doing wrong? :sweat:


#2

What is the variable auline currently at? If it’s 30-40, it’ll just skip because there’s no if statement for that range.


#3

Oh. It starts out at 30, and then it can grow or shrink (that cannot be the right terminology).

I’ll get back once I’ve edited the scene in question a bit. :rofl:


#4

Alright! I’m saying that with the current code, if the variable was at 31, it would skip over everything.

So you can write *if (auline <=30) and then *if (auline >=31) for the other one. You could also just make the other statement an *else so that anything 30+ would go to that one!

But let me know if that works or if it’s another issue :slight_smile:


#5

It’s working now! Thank you so much for the explanation! :smile:


#6

You’re welcome! Glad it worked and good luck with your code