How do i actually run the game... please help

*i suggest just scrolling down
so, ive been wanting to make a cyoa for a while now. now that i am in the process of making one, i cant get my game to run. when I ran the server, it just ran the default scene file. I thought that if i deleted it, it would run my game. Nah it cant run anything now. I have the needed files. I dont think theres something wrong with my code. i vaguely remember that you can upload what file to run, but i have absolutely no idea how to phrase that when searching threads here.
this is an embarassing first post

tldr: idk how to select/upload my game to let the server run it. please help

Hi, are you using CSIDE? CSIDE has a built-in playtest option so you could directly test your game while coding/writing. As for uploading to Dashingdon, you upload file startup.txt first, then the next scene in your scene_list. For example:


So when you upload, upload startup.txt first and then chapter1.txt (be mindful about capitalisation, chapter1.txt is not the same as Chapter1.txt)

If you don’t use CSIDE then I can’t really help you, since I don’t use traditional CS coding. You can download CSIDE though, it makes everything easier. Hope this helps.


You can download and put all your files on web/mygame folder, you can manually play your game and test it automatically too.

@Sargent also made a modified version on which you can extract the values of the stats you want to check them out and have more feedback about them. you can find that version here → Generate Statistics About Your Stats


This is the manual method. You’ll have to go through the entire process per replay, but it’s straightforward.

  1. Open the index.html file (…web/mygame/)
  2. “Upload” your file. Pick the folder where the entire CS is placed (the one that contains “doc”, “editor”, “test”, and “web”.)

  3. Profit

Omg this! I was gonna ask about some file problems but you were ahead of me! thanks alot!

im suprised this thread got noticed lol, yay! :smiley: thanks guys!

I’m trying that but I get this error every time after I upload the files.

How do I fix this and is there another way of testing the game? I have node downloaded but none of the quicktest options are opening

You probably have the word " *working " somewhere. All * mark a command for he game. like *comment *set *create etc… you can’t use * (at the start of the line at least, I don’t know if you could use it after the first word on a normal text)

You have an error in your code. Check again your variable declaration and follow Loudbeat’s suggestion.

I hadn’t been able to run my game until you posted this explanation so a massive thanks!

With the greatest of respect to the existing guidelines, they are very unclear:

I tried to do what was talked about 8 months ago and it doesn’t seem to work for me, I keep getting 404 error, is there anyway you guys can help like with screenshots or a video or anything that would help would be appreciated.

What SO, browser are you using? What exactly you do that leads to that error?