Help for cheeselouise


#1

I’m sorry that this is repetitive, but I’ve tried about a dozen different things that I’ve seen on the forum and none of them have worked. I’m getting the “scene navigator is undefined” error but downloading notepad++ and firefox hasn’t resolved the problem.

Other .js files in the program are also either showing error messages or not responsive at all.

Yeesh. I’d like to start writing and coding, but apparently I don’t have the tech prowess to start.

Any thoughts?


#2

The absolutely brilliant news is that you no longer actually need to edit the mygame.js file, and you also don’t need to touch any of the other js files. Is there a specific reason that you’re trying to?

Once you’ve read https://www.choiceofgames.com/make-your-own-games/choicescript-intro/

and

are good places to begin.


#3

Don’t mess with the mygame.js. What you want to edit is the .txt files in the scenes folder. To check your your use the index.html


#4

Come to think of it, I have no idea what made me start trying to mess with that file. My reading comprehension must have mysteriously tanked?

Thank you both so much, I know it’s really irritating to have newbies post stuff without reading all the FAQ, etc., I must have just missed those two pages. Sorry again, and thanks for the help. My blood pressure feels significantly lower already.


#5

That’s what we’re here for. :slight_smile:


#6

We’re here to help. :slight_smile: And you have shown yourself willing to help yourself.

There are actually instructions out there which say to edit mygame.js so I was worried that you were running off one of those. Things got changed though so you only ever need to edit and create text files, in the scenes folder, and don’t need to mess with anything else.

The wiki’s a fantastic source of info, as is Reaperoa’s guide. If you need any more help then feel free to ask. If you suspect you’ll need a lot of help it’s generally better if you do a CheeseLouise Needs Help thread as opposed to create a zillion different threads though.


#7

Thanks a bunch!

Yeah, I think that might be what happened, actually. I should’ve read the “how to create games” page more carefully, though.

Oh, thanks for the info. I went ahead and changed it, although I’ll try to read the guides, etc., before posting any more questions.


#8

Okay, so I’ve gone through the tutorial and figured out the basic variables and choices (enough to start tinkering on a first basic game, I think).

The only problem is that whenever I reboot my computer, the file just kind of breaks. The scene files all go back to the way they were, and the index only shows the buttons and example emails. Editing the scene files won’t even work, the only thing that works is totally deleting the zip file, redownloading and extracting it again. It’s weird, though, sometimes when I redownload it (I’ve tried this a few times with different strategies) the scene files display like I edited them.

All of this is really hit and miss. I can get it to work for a bit, then it won’t, etc etc etc.

I’ve searched the forum and wiki, but I can’t seem to find anything. Is this just an issue of having a really old, wonky computer, or is there something I can do to fix it?


#9

That seems really weird.

Are you certain that everything is unzipped? That you are using the unzipped folder and not the zipped one. That you are using the unzipped files and not a temp files folder?

Are you saving the files as text files in the scenes folder.

What text editor are you using?
What operating system are you using?


#10

I realized I had a couple of duplicates on my computer, so I deleted all of the files, downloaded a new one, and clicked “extract all files.” I tested the code that was in there, it worked fine, then I put in my own code and it only displayed:

“you@example.comSign Out
Show Stats Reset
Make your own games with ChoiceScript”

It’s not displaying an error message, either.

I’ve been switching back and forth between Notepad++ and notepad (because it wasn’t consistently saving my Notepad++ changes into my notepad files), but that last time I just used Notepad ++ . I checked the file in the scene folder, and it saved my changes into the notepad file.

Windows 7.


#11

Okay, I figured it out. I thought I was unzipping the file, but it turns out I needed to move all the files into a separate folder (even though I was getting dialogues that made me think I could convert the folder).