Forum not allowing editing the initial post

Since the last update to the forum software, editing the initial post has become impossible.
Upon saving one is prompted to ‘select at least 1 tag’ but the tag list is empty (except a few new ones) if one tries to add anything new.

All old tags are also gone from the list.
testing testing


Yeah just tried it on my post and I had the same problem :frowning:

1 Like

After struggling with it for a few minutes, I was able to edit mine, but I don’t know what I eventually did “right” that made it work

Discourse is being cranky this week–I had an issue with staff-level tags earlier.

1 Like

Do you mean “the initial post” of your own thread or any “initial post” you make of any thread, or something entirely different?

first post on a thread (i can’t english today Dx )

ok; is the “pencil” icon listed on the options for you?

I just revisited my oldest created threads and I am able to edit them still. The reason this might be relevant is that it might be tied to “regular” status and above now. If it is, this might be something Rachel might need to look at as forum administrator.

Edit - In the meantime, if you desire, your first post could be made into a WIKI post by a Leader or Moderator so anyone could edit it…

When I was attempting to change my initial post yesterday, the pencil was available to me (a regular), but like @MeltingPenguins said, it kept asking me to “choose at least one tag” before I could save the edit, and none of the old tags were available (gender-choice, nonbinary inclusive, etc), only stuff like tumblr and let’s play

1 Like

I have regular status and cannot edit my first post though :sweat_smile:

I’ll try to create a thread and see what happens then; which sub-fora were you creating the thread in?

Which thread were you attempting to edit?

It’s my own thread for my WIP. I just did it as a test to see if I could replicate it and I had the same problem as meltingpenguins and others.

1 Like

Also my WIP thread

1 Like

Wip thread here too

1 Like


It looks like @RETowers will need to look at editing privileges once more.

Until this has been resolved either way (old privileges re-established or new rules established) the only solution is to turn your initial posts into WIKI posts.

The advantage of doing this is you can edit the initial post.

The disadvantage is that everyone in the community will be able to do so.

A long time ago, the editing privileges were like this and we had to turn the initial posts into WIKIs … no one ever abused the editing (by editing another’s post) that I know of but since there is this danger, you should know about it.

Here's a screenshot if that helps...

It gives us the option to pick from like 5 tags that have nothing to do with WIPs or the option to create a tag ourselves to post. Which I would be hesitant to do since I’m not sure if that’s allowed.


I eventually successfully edited mine by choosing the tumblr tag at the expense of the other tags that no longer exist


ok… So for Regulars, you can edit the initial post but are forced to chose a new tag. For now choose the tumblr tag until Rachel can look into it.

@MeltingPenguins - can you edit your initial post if you chose a tag as well, or are you prevented from editing it at all?


Updated things, try again. (The forum gets auto updated, and I think one of the updates broke the “optional” part of what tags are allowed, forcing me to list allowed tag groups for each category.)


It worked for me!

1 Like

Didn’t work for me because all my tags got wiped out a couple of days ago by a mod.

With mod permission can I put my tags back on my post?

1 Like