Does anyone else get this issue? "Securityerror: Permission denied to access property "getContent" on cross-origin object

I’m trying out choicescript for the first time, for the most part it’s not difficult to understand, but I cannot figure this out.

Where do you get it from? testing in random test or quicktest?

Search the forum…or read this here there has been similar post that has been resolved

1 Like

I opened index on firefox, from the editor and then I tried I check properties and tried to allow access, but it still isnt working.

Please take note of this thread if you haven’t already:

1 Like

Yes I’ve tried that.

I opened index in my editor, then I changed the title name, just to test everything for the first time. It still doesn’t seem to work.

Ok let’s check this together…you have downloaded choicessript from github? and you extracted the zip file?


Did you get the package with all the folders? like below

Or if you are using choicescript IDE your files would look different more like this

I used google chrome and windows 10 to download the files… maybe try with google chrome instead of firefox…

Also, are you using a Chromebook? here’s a link to extract files on Chromebook…this

I just used the index in the editor and I had the same error message…

You said something about using the index in the editor folder,

Can you try using the index that is outside of the editor folder…or the one in the web folder…see below…


Remember that the folder you will work with is the web folder…that is where all your scenes files are… and you can use quicktest html and randomtest html to run tests.

1 Like

Thank you all for your help. I managed to figure it out.

1 Like

Sorry this question isn’t related to the thread but how did you do this and what is it used for?

1 Like

lol I have no idea what it is is it just a screenshot from this link here here
lol I just needed something to show how ide would look like

1 Like

This topic was automatically closed 24 hours after the last reply. If you want to reopen your WiP, contact the @moderators.