Dashingdon: Free ChoiceScript Game Hosting

No, you can only access your saves from the same device and browser as the one you used to create the save. That’s just the way CJW’s plugin works. The dashingdon.com site does not retain or access any savegame data.

This is odd. I’ve checked your email myself and I cannot duplicate that error. It looks as if the @ symbol isn’t being recognized? Is there a reason that might be happening? Are you using non-US/UK input maybe?

2 Likes

Did you put in the Email adress by typing it or did you use the auto-insert some smartphones and tablets use? At my Work there is an issue with recognizing Auto inserted e-mail adresses.

You might want to try to delete the last sign and then type it again .

2 Likes

I was using the auto insert for my email.
Typing it in works.
@dashingdon I found the issue. Using the auto insert option brings up the problem, but typing it in doesn’t.

1 Like

@dashingdon thanks for the quick fix. None of the links work now.

1 Like

I see. The validation script must not recognize the auto-insert as valid. I believe you can still do the auto-insert to fill in the form but you may need to add an extra character in the field (like an x after your email address) and then delete it to get the script to evaluate the field value. I’ll look into finding a way to fix this when I have time.

1 Like

I have done everything that I could think of to work around this issue, but I just can’t seem to update my game.

The problem: uploading new versions of existing TXT or JPG assets doesn’t work. I tried adding a new TXT with a new name and it worked fine. I verified that the files weren’t updated two ways: firstly by checking the files on the server (I have an update date near the top of every file) and second by manually replaying the demo and seeing that it didn’t update.

What I tried: I tried it in both Firefox and Chrome. I tried logging out and then back in again. I tried restarting Firefox to update the browser version. I tried CTRL+F5 to force refresh. I tried playing in a private window. I quit the browser and cleared all cookies across all browsers in my system using Avast. I tried creating a new game and couldn’t get past the screen where you input a name for the game.

I am at my wits’ end. My next ideas are creating a brand-new Dashingdon account or reloading reality from a recent save. Please advise.

The game link, in case it’s needed: https://dashingdon.com/play/hazel/the-flower-of-fairmont/mygame/

1 Like

Hmm that’s very strange… but the only odd thing I noticed was that four of the scene files had the wrong permissions on them. No idea how that could have happened but I’ve adjusted the permissions now. Hopefully that fixes the issue you are experiencing with the file uploads.

If not I’ll have to dig into this more tomorrow when I have time - along with the problem you’re having with creating a new game.

5 Likes

My best guess would be something in the transactionality of the update – the file locked for updating, the update failed, and then the lock never released. But this is just an educated guess, without knowing too much about your infrastructure.

I’ve used the site for years, mostly with no issues, so this is an outlier for me.

Edit: Okay, this is weird. I tried again, and got the same issue. It’s very strange that this happens with the main project, when I updated my private beta version this Sunday. And stranger still that trying to create a new project gives a Secure Connection Failed browser error.

1 Like

Is dashingdon’s currently offline? I’ve been having trouble accessing it and am wondering if it’s a problem at my end or not?

In some connections it says that the SSL certificate expired. Same for the forum too. But I still can access through phone and tablets.

It might be an issue on my end though.

Doesn’t seem to work for me either, tried it on a phone and computer.