"Couldn't load scene. The file doesn’t exist" error in CSIDE?

Hi! Im having the most frustrating error right now, its driving me fully nuts.

Heres my code:


     #Push on with the expedition. Fortune favors the bold.
       *set Calculated - 3
       *goto_scene expedition

     #Return home. You weren't one to be reckless, and you sure as 
      hell wont be reckless now
       *set Calculated + 3
       *goto_scene stay


Now the issue is, the first choice loads perfectly. It goes to the scene named ‘expedition’ and carries on exactly as i intend.

When i want to choose the second option, however, it tells me “Couldn’t load scene ‘stay’. The file doesn’t exist”.

Yes, i spelt ‘stay’ correctly in both cases.

Putting in/removing the scene from my start up file doesn’t fix the error.

I tried different indentations and tried to use the *finish command for both and no damn dice.

If i could post pictures i would, whats up?

I was running into a huge issue with CSIDE saying it couldn’t find my entire project. The only thing that fixed it was uninstalling and then re-installing CSIDE. Maybe try that?

Put the same code in a completely new project and it worked perfectly well. Im going to conclude that CSIDE hates this project in particular and try this out

If i delete CSIDE, will i lose all my project though?

No, it’ll keep the folder with the saves, but I still copied my project and pasted it into a folder somewhere else (because you can’t be too careful, right?)

1 Like

I moved everything in my “stay” scene file to a new, differently name scene file and that seemed to do the trick.

Seems like CSIDE actually just had beef with the “stay” scene itself for some reason(?)

Either way, its resolved. Thanks for the advice! I’ll keep uninstalling and reinstalling it in mind next time CSIDE decides all my scene files are evil

1 Like

The scenes are case sensitive in choicescript, so it can flip out if the notepad/whatever file in your documents is capitalised differently from in CSIDE.

That can also cause this error.


This is the likely cause. You shouldn’t need to reinstall everything to get it to work.

This topic was automatically closed 24 hours after the last reply. If you want to reopen your WiP, contact the moderators.