Compile stuck on loading


#1

So I’m really new to this. But I’ve got the basics done. Followed the tutorial on wiki and made my first .txt pages (I tested it with the Choicescript IDE, everything works). But when I try to run Compile.html … its just stuck on “loading”. Using firefox and also tried IE. It stays stuck and I cant figure out whats wrong.

Also, I tried using the choicescript IDE first, since its obviously alot easier to use. I exported the “file”, which should be a single html file. It’s a single file but when downloading its not specifically named as .html. So I rename it and try to run it, but it just shows garbled html text, and not the actual page it’s supposed to show. I have no idea why this is. Especially since on the IDE website itself the whole thing works flawlessly.

I’m terribly stuck x_x


#2

Sorry about the IDE putting out garbage, I’ve just implemented a quick-fix for that although long story short, the web IDE is long overdue a revision (hopefully early this year) - I apologise for any quirks that’ve come about as a result of its recent neglect.

As for the compile.html, double check you’re using the latest Firefox and the latest CS (from Github) - if you’re still having issues, feel free to PM a .zip of your game, and I’ll see if I can’t identify the issue.


#3

Thanks for the quick reply! I didn’t realize the IDE was outdated, so I had no clue what I was doing wrong. Good to hear it’s not a fault on my side.

With CS, what do you mean? And I believe I am using the latest firefox, I just recently reinstalled windows and downloaded Firefox straight from their website, so it should be more then up to date (and it should auto update itself I believe).

Edit: CS = Choicescript, right. Obvious one. Errr… I went to https://www.choiceofgames.com/make-your-own-games/choicescript-intro/ and just downloaded from the link there, it says its from Github.

Also running the index.html file from there works fine, quicktest.html and randomtest.html ALSO work perfectly fine and recognise all the .txt files from my “test game” correctly. It’s just that compile.html is stuck on loading and doesnt seem to be working at all.


#4

Not massively so, it’s perfectly useable - It’s just that I’ve just been working on a big overhaul of it, and whilst doing so have been neglecting to update the current one (and thus overlooking things like broken compile functionality!).

Yup that should be the latest then, so I’m not sure what could be wrong if the code works.
It could be a recently introduced bug, but I don’t develop Choicescript, so couldn’t be certain - does it work with the demo scenes? Before you’ve edited them?


#5

Before I edited it also didn’t work, the compile file that is.

And yea the IDE is perfectly usable, and I would prefer it in fact. But it doesn’t help if I can’t export whatever I’m making.


#6

It should export just fine now - I’ll investigate compile.html as well.


#7

Yay! Great work on the IDE btw, it’s so much easier to work with it.

The garbled html is gone and it shows a proper page now, unfortunately it does drop out errors:

Couldn’t load URL: scenes/startup.txt
NS_ERROR_DOM_BAD_URI: Access to restricted URI denied)

Edit: And now

authorTag is null

I’ll close the URL/refresh in a bit later, you’re probably still working on the code.


#8

Ah… 2secs…characterlimit


#9

If you want me to link the code I’m using for the startup page? Does that help?


#10

Yes please, it certainly wouldn’t hurt.


#11
*title TheInnkeeper
*author Drhankeey
*scene_list
    startup
    rainy_walk
    horse_ride
    stay_home
    
*create Money 0
*create Name "Unknown"

Greetings fellow readers! This will be a short but joyful visit to the innkeeper. Are you ready? Press Next below!

*page_break

It is a rainy afternoon, the sky is grey and the weather is very stormy. Sitting bored at home, you decide to do something.

*choice
    #Go out towards the nearest inn!
        Bored as it is, you decide to venture outside and look for the nearest inn!
        *choice
            #You decide to walk in search for an inn nearby, after all how bad could the rain be?
                *page_break
                *goto_scene rainy_walk
            #The storm outside is quite bad, I better mount up on my crafty horse!
                *page_break
                *goto_scene horse_ride
            #Actually, nevermind.. I'll stay home after all.
                *page_break
                *goto_scene stay_home
    #Stay at home
        Cold as it is, you decide to stay inside, put on the heat and make yourself a hot cup of chocolate milk. Splendid!
        *page_break
        *goto_scene stay_home

#12

I use other pages for the scenes, but it’s just a line with *ending at the end. Shouldn’t contain any problems.

Also on the IDE if I just press “Run” it works flawlessly in the browser there. So I’m not sure what the exact problem could be.

Edit: Just double checked firefox aswell, version.34.0.5, and it says “up to date”. Tried IE but gives similar errors.


#13

OK thanks, I’ve hot-fixed the author issue too, everything should work fine now… Touch wood! The compile code used in the online IDE is a bit ancient, that’s the cusp of all the problems you’ve been having, I need to replace it (and many other things), but don’t have access to my usual development PC for another week or so - but hopefully this will do for the time being.

Sorry about all that!


#14

Huzzah! It works now, thanks so much. :smile:

And thanks also for the quick replies. At first I thought it was a problem on my side, especially with the compile.html also not working when I tried to do all that manually. But I suppose people might’ve just neglected to report this bug or something. Either way happy it works again. Looking forward for the newer versions.


#15

Hey my compile.html is still stuck on loading, I have my Firefox updated and the reason im not using the IDE is because I wanted to use the Save plugin so my friends dont have to read my whole story at once for the lengthy demo. Is there something I can try to fix my problem? If you need any information from me or the story please feel free to ask.


#16

Sounds like you’re probably using a version of CS where compile is broken, make sure you’ve got the latest one (which seems to be working just fine for me): https://github.com/dfabulich/choicescript


#17

Hey I tried using the latest one but its still stuck on loading, I launched it with IE too but it did the same thing. The other HTML files work just fine (Auto test, Random test). If it works for you I’m sure it’s me being a idiot. Does anything come to mind?


#18

Pop open your Firefox console (F12) (whilst you’re attempting to run it) and post any errors it comes up with here?


#19

"ReferenceError: doneLoading is not defined compile.html:68

The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol.


#20

Definitely sounds like you’re using an old copy… Are you sure you downloaded a fresh .zip and aren’t accidentally using the old one? Don’t just copy compile.html over, move all your scene files (and only you’re scene files) to the new directory.