ChoiceScript crashing


#1

Hello. Lately I’ve been having trouble getting ChoiceScript games to run. Usually what happens when I click on the link is that it crashes after loading the first few paragraphs of the page and displays the error message “main.appendChild is not a function”. Does anyone know why this would happen, and if so, how I can fix it?


#2

Is there a particular game you’re trying to run? If it’s a custom one, have you edited any of the files (namely any of the .js or index.html)?


#3

What browser and device (mobile, computer/Operating system) are you using?


#4

I’m using a Lenovo laptop running Windows 7 Home Premium. It doesn’t seem to matter what browser I’m running, it happens with both Firefox and Chrome.


#5

Do you have any addons that could be conflicting with choicescript?


#6

It seems to be happening with all games, not any one in particular. And I don’t believe it’s due to any plugins or addons, I didn’t install any new ones in between when it last worked and now. I’m really not sure what’s going on.


#7

And just as suddenly as the problems started, they have vanished. Well, that was odd. I don’t understand what went wrong, but it’s evidently resolved itself. I just tried loading a game and it’s working fine for me now. Thanks for the help, even if I turned out to not need it.


#8

If I had to take a guess, something was causing the page to load slowly (slow internet connection?) and it was trying to execute a script before an element had rendered or vice versa. Glad to hear it’s sorted though, happy gaming!