Can anything happen after a *goto_scene?

This has always worked fine, but I split a scene this afternoon and now it doesn’t.

At the end of my scene I have a:
*goto_scene next_scene

It ran into some of my subroutines I have at the end, so I wrote this;

*bug This can’t be reached.

I put that the line after the *goto_scene and surprising to me, it triggered the *bug.

Why didn’t it go to the next_scene file? It didn’t give me any errors about being a bad *goto_scene.

1 Like

First possibility to come to mind would be a stray *return somewhere?

Edit: like, is there a chance it slips into a subroutine that somehow ends up not displaying anything?

1 Like

Nope.

I checked that it never accidentally fell into the routine by using the *bug command.

Eg
*goto_scene 10_arms_race

*bug How could this bug trigger?

*label Some procedures.
Stuff happens.
*return

—-

How could that *bug trigger instead of opening 10_arms_race.txt ?

By placing the *bug there, it eliminates a lot of other places the error could be.

wow even Lucid still got problems with CS

I don’t think I can really help, but AFAIK goto_scene needs the file name and its label,
so it’s: goto_scene 10_arms_race initiate_race ← the label

I’m not sure but that’s what comes to mind when facing goto_scene command

1 Like

If it’s something like that we really need someone to make a thorough tutorial

1 Like

*goto_scene doesn’t need a label as part of the command.

I did wonder if the CS parser looks to see if there is a label though, whereby it ‘reads ahead’ - thus encountering the bug command.

A simple test suggests that isn’t the case.

@Lucid Can you recreate the bug using different files? I have just tried and nothing looks odd to me.
Are you sure that your labels, after the *goto_scene aren’t being accessed in some other way?

1 Like

So, it mysteriously works now.

Because it was happening at the 3/4 mark of the game, I wrote code to jump to just before it, and it worked.

I then went over to my phone, loaded a saved game, and it went through the spot just fine too.

Well, it works. I was breaking a scene, so the new scene it went to was brand new. I wonder if it was a DashingDon thing, maybe with cached or old files or something? But still, I just don’t know how it jumped past the *goto_scene to trigger that *bug, so I guess my original question still stands, but only out of curiosity now: Can anything happen after a *goto_scene?

Thanks for your help everyone.

I sure do! In my defence, some of my problems occur because CS has changed over the years. I still can’t test my games offline because of the whole “only old versions of Firefox” thing, but with DashingDon, I haven’t tried too hard to get it to work either. (Actually, I’m not even sure if that’s still a thing! :slight_smile: )

1 Like

Thought the same thing, lol. (I also have problems with it sometimes)

You sure? I’m using the latest version of Firefox (formatted the computer recently) and it works fine.

I do remember at one point downloading the latest version of the ChoiceScript .zip and importing old scenes into the folder, then noticing that the way playtests happen had changed. Maybe you’re using an old CS bundle like I was.

I did that a couple of times, and you’re absolutely right, I’m not even sure how old my current set is. It became less and less of a problem as I gained more connectivity. Now I prefer it on DashingDon anyway, since it let’s me test it on my laptop or on my phone.

Still though, thanks for letting me know it’s working. That might be worth the update.

version for CS that works with the current FF is at least 11a5300 (that’s the one i’m using, dunno if it’s uptodate)
edit: checked. newest version is 4f640f6

1 Like