What other browser can be used to code the choicescript?

That sounds like there’s something very wrong with your installation of Firefox. Try following these steps: https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help