TypeError: window.onerror is not a function


#1

I’m getting this really weird error when running randomtest. It keeps happening in the “puzzle” scene for my Judgement of the Fallen beta, but I have no idea why. “puzzle” is listed in the *scene_list, and the file itself is saved in the scenes folder. Can anyone help me with this?


#2

@CJW
Sorry to single you out, but I thought you may have some ideas as to how I could fix this, since you’re the coding guru :stuck_out_tongue:


#3

That sounds like a bug in my code. Email your scenes folder to support@choiceofgames.com and we’ll investigate.


#4

@dfabulich
Okay! Thank you.


#5

I had that error too but with quicktest.


#6

@Nocturnal_Stillness
Oooooops. It was actually in quicktest for me, too, which is probably a good thing for @danfabulich to know xD


#7

@Samuel_H_Young
Flattered :slight_smile:
But it does sound like it’s a problem with the tester code… Hmm.

I did notice Dan has actually updated Choicescript since you posted this, so it may be worth downloading a fresh copy and trying again (although if he’d fixed it he probably would have said, but it can’t hurt to try!).


#8

I had that error several times in my phone and problem was always a puntuation symbol or lettermisplaced or appear lines below real end of text.


#9

I got this error once, I narrowed it down by

  1. deleting a chunk of code
  2. trying quicktest again
  3. if the error persisted, I’d start again with the next chunk
  4. if not, I’d start again but this time deleting sections of the chunk to check where the error was
  5. once I located a few lines of faulty code, I’d double-check them
  6. if the error still persists, try deleting and rewriting the code
  7. if the error STILL persists even though your code appears like it’s fine (mine did), I’d suggest my method as a last resort: just delete the code. It worked for me because that code wasn’t particularly important.
    Hope you find out what’s wrong.

#10

EDIT
@CJW
Sadly, it didn’t work. Urgh

@poison_mara and @gkkiller
Thanks for the advice. I’ll go and scour my code for any mistakes that could have caused this.


#11

I think I found the error my end a bit of the code said *else if instead of *elseif


#12

@Nocturnal_Stillness
Can *elseif be used to check variables? I’ve rarely been able to check them with *else, because it always says “Choices must end in *finish, or *goto, bla bla bla”


#13

Yes could be used easily always you let clear the goto finish goto scene commands in each im more of use a multiple ifs labels normaly


#14

@poison_mara
Wow, I’ve been missing out this entire time T.T


#15

Yeah Unnatural has a few *elseif 's


#16

Sam I use many, if labels its useful to me due you haven’t to spefic a destiny in each you could do all if and at the end send same destiny to all in a mobile where you couldn’t see all code in the tiny screen its an improvement and avoid silly errors


#17

Yeah I use a lot of labels. Does *elseif basically pick up anything that the other if didn’t? Like


\*if red
   you are red
\*elseif
   You are not red
<\\pre>

#18

You could use too


*if red
    You are red
*if not(red)
    You are no red


#19

@poison_mara
Really :0? I didn’t even know that was a command. That makes thing’s so much easier.


#20

Sam, it’s not a command per se, its logical writing like the use of > = < and others. I use them due i have to reduce all stats to bare bones to code efficiently in a mobile use negative and if makes my code way more efficient.
Like to follow your example


*if red
    You always love red
*if ((not(red))and(blue))
    You don't like red you prefer blue.