"The ORPHEUS Ruse" on Steam


#1

To celebrate today’s launch of Paul Gresty’s MetaHuman Inc., we’re also making his top-rated game, The ORPHEUS Ruse, available now on Steam for Windows, Mac, and Linux. (It’s still available for iOS and Android devices, too.)

Infiltrate the enemy as a psychic spy, leaping from body to body by touch! But when your own body is stolen, you’ll race against time to find it before your mind disintegrates.

The ORPHEUS Ruse is a thrilling interactive spy novel by Paul Gresty, where your choices control the story. It’s entirely text-based–without graphics or sound effects–and fueled by the vast, unstoppable power of your imagination.

What secrets have your mentors been keeping from you? Can you trust your friends when you don’t know whose face they’re wearing? What will you sacrifice to hide your powers from the world?


#2

I’m not sure if this is a bug or my computer’s fault, but every time I try to launch this on Steam it crashes without ever opening. I don’t have this problem with any other CoG game or Hosted Game I own on Steam, just this one. So I thought I should share, just in case it is a bug.

EDIT: The weirdest part is after it crashes Steam and I relaunch it, it lists the game as running, even though it’s nowhere to be found in the Task Manager, forcing me to restart my computer to play any Steam game.


#3

That’s alarming. We did just update Orpheus Ruse on Steam, but it seems to work on the machine I tested.

Did you say the game crashes, or Steam crashes, or both?

I assume by the way you told the story, rebooting doesn’t help. Have you tried uninstalling and reinstalling the game? Right-click on Orpheus Ruse in your library and “Delete Local Content.”

Are you on Windows? Which version?


#4

I just opened my Steam copy this morning and it worked great.

@bookworm37 - be sure to check the cache it sounds to me like there is corruption in the code downloaded somewhere. If you right click on the title in steam, it will open the option to check the game’s cache. (in case you did not know)


#5

The first time I tried running it just the game wouldn’t open. It loaded for a long time, froze up, and then crashed leaving the Steam client open. After I noticed it still said it was running in the Steam client, I tried loading it up and it said it was already running. So I restarted my computer and tried again, and that time Steam crashed too. But when I restarted Steam, it still said the game was running (so I restarted my whole computer again).

I’ll try uninstalling and reinstalling the game, see if that works. I’m starting to wonder if it IS my computer, since it does seem to be working for everyone else.

I’m running Windows 7.

@Zolataya I’ll try checking that too, thanks.

EDIT: So I tried both uninstalling/reinstalling the game, and checking the cache (it said all files were successfully validated), but it’s still showing the game as running despite not being there at all. I was going to contact Steam support, thinking it might be a client issue, but it just redirected me to contacting Choice of Games, and I’m pretty sure it’s not a game bug at this point.

EDIT 2: Okay, now I’m also encountering the error with HeroFall, further convincing me it’s an issue with either my computer or Steam. I apologize for clogging up this thread, I just wanted to confirm that I’m pretty sure it’s not a bug or anything that should effect anyone else.


#6

You not alone when I try the ORPHEUS game I have the exact same problem as you stated. I not try the other games if they have issue too. I contacted steam support and they said to me that it not their system that is causing it to close, but they are going to look into it. They mentioned to contact Choice of Games as well, but I saw this and just posted what I have encountered there. I am using windows 10.