*SOLVED* Problem with *choice statement


#1

First Time ChoiceScripter. In my game, I have a choice with two options in it. One choice works perfectly fine, while the other gives me an error saying that i am falling out of the *choice statement without a *goto or *finish. But I have a *goto statement at the end of the option.

(Since i cant seem to tab out the preformatted work I will use TAB to represent tab strokes, and ENT to represent Enter Strokes)

#(Take the Purple Pill) ENT-TAB Hm, so you decided to take the Purple pill. Not what I would have picked. Carry on. ENT-TAB *goto BallMove

I dont know why it isnt working. It even says it is good when I run the quicktest Snippit of the aforementioned code


#2

I can’t see a choice option in there (Although the formatting looks weird on my computer so maybe there’s more problems there as well). What’s the exact error you’re getting? (It’ll often give you a line number)
ie
*choice
(tab) # take pill
(tab x 2) Hm…


#3

Actually the above coding seems wrong as well. You’re mixing simple choices with else if statements without there actually seeming to be a choice command in there. See this page for using those commands in choices https://www.choiceofgames.com/make-your-own-games/choicescript-intro/


#4

Sorry, I was a bit unclear about what I said beforehand. Let me PM you the full page rather than a snippit so that you could help a little further.