Run-server.bat file not working?

Hey, up to now I have been heavily struggling to start doing anything, from the moment I found about ChoiceScript yesterday. After some time I found SCIDE and decided to go with it since it worked in the browser (I’m with Windows 7 so the install is not launching).

Suddenly I lost connection, I’m not sure from where to where, but the IDE stopped working online and I lost some code. So I decided to try node.js after all, so I can work “offline”, although only the IDE lost connection, anything else in my browser was fine.

I downloaded both node and the zip for the ChoiceScript but, after extracting, the run-server.bat file didn’t work. I went on a rabbit hole venture to find how to launch it properly, but no luck. I get an error from Windows cmd - " ‘node’ is not recognized as an internal or external command, operable program or batch file."

I have no idea what to do.

Forgive me if this sounds like a stupid question, but did you install node?

So, weird thing, Windows 7 doesn’t support anything above node 14. I had to install node 13, but instead of a usual install wizard, like the one for 14 and above (that said the version is not supported on Win 7), I just downloaded an exe file from an archive, that opens a command prompt. Along with it were some other files, but they weren’t recognized by windows, neither node worked differently with or without them (that also applies for when I tried to run the run-server.bat).

So to answer your question, I’m not really sure.

I would suggest you go and download .msi instead of .zip or whatever it is you downloaded…? From what I see, there should be those available too; maybe you accidentally downloaded a wrong file.


This worked, thank you.
I got what the problem was :sweat_smile: . It appears that I have downloaded the naked .exe file that didn’t work properly with the bat file because it wasn’t installed into Windows, but rather it was just sitting there aimlessly. It needed to be integrated into a global windows variable PATH for .bat files to work with node.
And all of this, because I couldn’t be bothered to scroll a little bit further to find the .msi … :expressionless: .

node.exe serve.js should have worked.
But, please, please, consider upgrading your OS. AFAIK you can still get Windows 10 for free with a win7 key.

Potato PC is not for Windows 10 but after some time I’ll probably just get a new one. Until then I’ll deal with frustration :clap: .

By the way, I’ve replied to your bug report on the CSIDE website.There is also the CSIDE thread, if you prefer to discuss there: [CSIDE] The ChoiceScript IDE (v1.3.0 Now Available — 18/06/2019)


It’s really a pain to change OS because you have to backup all your files. But if you’re willing, maybe consider installing a lightweight Linux distro if the hardware won’t support heavier OS. I’ve done it recently and managed to make an old PC actually usable, so I made it into a home FTP server. :grin:

I suggest Zorin OS (which has a lightweight version) for people transitioning from windows to Linux.


This topic was automatically closed 24 hours after the last reply. If you want to reopen your WiP, contact the moderators.