Random Test and Quick Test Error... Help? (SOLVED)


#2

It sounds like you're using a file that still has the *check_purchase command in it, which is something CoG uses for published games that are either paid for/no ads or free samples/ads with later chapters you have to buy.

Look for *check_purchase in the startup file you're using and remove it, and any other lines of code related to it. You don't need them.


#3

@distracteddad
Do you mean something other than startup.txt? I already looked there. What is the file called that has this?


#4

Startup.txt

Quicktest and randomtest work on the startup.txt file that's located in the web\mygame\scenes folder.


#5

@distracteddad
There is nothing in the startup.txt file in the scenes folder with the command *check


#6

Huh. Is there ANYTHING in the startup file that has anything to do with either check purchases, or resetting them, or anything? Startup should have *title, *scene_list, *create and then the game text. (Also *author but I leave it out because it doesn't always work on my version.)


#7

@distracteddad The only commands are
*title
*author
*create
*set
*goto
*label
*scene_list
*comment
*fake_choice
*input_text
*if
*page_break
*finish


#8

Also a quick ctrl+f searching for "che" finds only the final message

"Keep Checking our page often! We will be releasing frequent updates."

And when searching for "pur" it finds nothing.


#9

Sorry I can't be more help. Hopefully somebody else will have a better idea. The only other thing I can think of is that you've got quicktest and randomtest in the wrong place. For me -- and they work -- I have quicktest and randomtest in the main choicescript folder (dfabulich-choicescript-0cdb371) and then the startup and other game files are in the web\mygame\scenes subfolder.


#10

@distracteddad thanks for trying! I'm not sure what is wrong either, I have renamed the folder name but I doubt that would be it because then it wouldn't be able to reach the text file.


#11

Have you tried re-downloading choicescript and dropping your game's .txt files into the new choicescript folder?

It almost sounds as if your choicescript files have gotten in a twist somehow. (Terribly technical, I know.)


#12

@Fiogan ok, yeah, I could. :pensive: The only thing is I'm helping others code their games so total I thing I have like 40 text files. I know really small but I was hoping for a quick fix. Also I have a mod installed so that will have to be redone.

Thanks though.


#13

@Fiogan @distracteddad Would it make a difference if I am trying to run the tests from dropbox files instead of off computer files?

[EDIT] - I just attempted it and it didn't work... I guess I'll be redownloading then.


#14

Oh . . . I keep my game files in separate choice script folders so as to keep things tidy and non-muddled. Also because sometimes choicescript updates, so whenever I start a new game I make sure I'm using the latest version. Useful because games can take years to complete and such.

And . . . I don't know? I wouldn't think so.


#15

I do this as well. but this way I can keep them with the compiled html files as well. Also I can share the files with people I am working with by folder through dropbox


#16

Also I downloaded choice script this past January when I discovered the site and this forum. I started the game not a month after.


#17

Ah, I see, I think. So when you run randomtest and quicktest, where are you running them from? And how?

I know I usually open quicktest.html in Firefox, by right-clicking on the file name from inside my choicescript folder for the game in question - but I'm not sure how that would work if I had several games worth of code in one choicescript folder. Does that mean there are multiple startup.txts within the same folder? Or am I misunderstanding what you're doing?


#18

@Fiogan @distracteddad I just tried with another game and it worked :astonished:

idk why this would work because I literally copied and pasted the folders. problem solved I believe.

Thank you both so much. I apologize for wasting your time.


#19

Never a waste, not at all.


#20

Thanks @Fiogan you were right after all. The quicktest was only working for startup then it popped up with the same message so I re-downloaded the files from the site tested it and it worked. Cannot thank you enough. This will save me so much time.

testing process:

Re-downloaded. Moved to Dropbox. Works.

Copy and pasted into the index thing then changed some stuff then copy and pasted back in. Still works.

Changed name. Still Works.

Copy and pasted Original problematic text files. Works.

compiled file and inserted that into folder. Works.

Re-download mod. Doesn't work.


#21

The problem was in the mod I installed.