Is anyone else having issues with running their game on local?

So, I tried to run my game on local through first google crome, as it seemed to be working through that, then firefox, after, something happened?
For reference, when ever I try to load my game, I get sent to this page:
file:///C:/Users/adpco/OneDrive/Documents/dfabulich-choicescript-16c10bc/web/mygame/index.html
At which point, I get shown the screen that I would get if I had found a glitch or something that I had to change, but now it’s doing it directly after I load the game, and there are no error messages. I’m a little confused, and curious if anyone else is running into this, or if it’s just me?
Anyway, I hope that who ever reads this has a good rest of your day, and, yeah.

I also have problems running most games on a browser, usually I just get the title of the game, and a blank screen with nothing on it.

Edit: rereading this I guess you don’t mean published games lmao.

2 Likes

Are you able to run quicktest or randomtest on the game? If so, do those produce any errors?

I meant as in my personal game that I’m creating. It only started like four days ago?
Have not tried either quick test or random test yet, as for a long while, due to my old computer, they wouldn’t work. Will look into that and see if they work now. Thank you. :slight_smile:
If this helps, I have the website thingy bookmarked on my computer, as in I initially went through the game file to find it, then bookmark the website, so I’d be able to jump back there quickly later on. When I first tried it a couple of times, it kept saying that there was an error, as in not in the game itself, but in the webpage? I’m confused.

1 Like

It might be that somehow the index file itself got messed up.

You could try downloading a fresh version of Choicescript from GitHub: GitHub - dfabulich/choicescript: ChoiceScript is a language for developing multiple-choice games.

Just make sure you copy your existing game files elsewhere (in my opinion, you should always have a backup of your game files anyway!), and then move them into the new web/mygame/scenes directory.

1 Like

So, the quicktest works, although it keeps saying it can’t open Phonecall.text, and I can’t figure out why that file would be different from the others, though perhaps I will re-download choicescript regardless, since i’ve got the game files on an external drive, and should really update them more often anyway.

  1. Make sure you’ve loaded the server.
  2. Try running it via firefox
  3. Put the files into dashingdon or moody and see if it runs there. If it runs there it’s not your coding. Maybe try re-downloading the CS package.
1 Like

I downloaded the CS package and it seems to work now, although I’ve never heard of a line being visited too many times before? As it’s giving me that error.
Error:

Crate line 2214: line visited too many times (1000)

No idea what that’s about, but at least now I know it’s my codeing, which I can fix, and not something with the CS package itself, as I have no idea about going about fixing issues with that apart from, as I did, re-downloading it.
Also, thanks for all the suggestions and what not for this.

1 Like

Sounds like an infinite loop.

2 Likes

Sometimes, the “line visited too many times” error is caused by a label being called too many times.

Each label can only be called up to three times before this error occurs.

1 Like

So you’re saying it has to do with me having, more than three in this case elseifs that connect to that label?
I am pretty sure that is what a label being called, refers to.

Yes, if that label gets used more than three times in a single test, that test will fail and throw up that message.

I learned this the hard way, and it took many hours to figure this out (again thank you, @Jacic for the post long ago).

The solution is to just add a second label below the first or a third below the second as needed.

2 Likes

Wait, that doesn’t sound right.

I just tested this code, and it passes Quicktest and Randomtest.

*temp num

*choice
  #1
    *set num 1
    *goto print
  #2
    *set num 2
    *goto print
  #3
    *set num 3
    *goto print
  #4
    *set num 4
    *goto print
  #5
    *set num 5
    *goto print


*label print
*if num = 1
  1
  *goto done
*elseif num = 2
  2
  *goto done
*elseif num = 3
  3
  *goto done
*elseif num = 4
  4
  *goto done
*elseif num = 5
  5
  *goto done


*label done
done
2 Likes

Perhaps I am not clear enough or perhaps did not explain it well.

Here is the original issue and solution in Jacic’s words and then I’ll add what else I discovered:

So it is callbacks that are limited to two. Jacic’s code dealt with only script within a scene, but I also discovered on my own that this maximum of two loop backs even applies when the origins is a different scene.

Edit:

Here is a bit of my script, with an extreme number of labels I had to use showing. Perhaps this will help you understand as well. @dfabulich

*label codex_start

*text_image codexheaderone.png center The Codex

The Codex is made of three distinct parts.

First, there is the Compendium where everything related to the characters of [i]Patchwerks[/i] is located.

Next is the Encyclopedia, the place where all the questions you have about the world you find yourself in are answered.

Third is Character Relations, the place you go for the lowdown on how others view your relationship with them. 

*label submenu1
*label submenu2
*label submenu3
*label submenu4
*label submenu5
*label submenu6
*label submenu7
*label submenu8
*label submenu9
*label submenu10
*label submenu11
*label submenu12
*label submenu13
*label submenu14
*label submenu15
*label submenu16
*label submenu17
*label submenu18

Which part of the Codex do you wish to access?


*if choice_randomtest
    *goto randomchoice1
    

*choice
    #Compendium - For everything character related.
        *label randomchoice1
        *if (choice_randomtest)
            *goto_scene 1_frontend authors_note
        *else
            *goto compendium
    #Encyclopedia - For information on the world you find yourself in.
        *goto encyclopedia
    #Character Relations - For everything relationship related.
        *goto relations
    #Exit the Codex entirely
        *return

*label compendium

*text_image codexheadertwo.png center The Compendium

*label compendium_directory1
*label compendium_directory2
*label compendium_directory3
*label compendium_directory4
*label compendium_directory5

The Compendium is where everything related to the characters of [i]Patchwerks[/i] is located.

Which section of the Compendium do you open?
*choice
    #Companion Profiles
        *goto companion_profiles
    #Notable Citizen Blurbs
        *goto notable_citizens
    #Patchwerk's Pantheon Guide
        *goto deity_profiles
    #Return to the Codex Directory
        *goto submenu1

I hope this helps clear things up

1 Like

@jacic reported “too much recursion,” not “line visited too many times”; they’re different.

I see that you’re using an extreme number of labels, and I believe you that you needed to, but you’re not “supposed” to need to. That suggests a bug in my code.

What I’d like to do is develop a “reduced” example, the smallest possible code snippet where we could say “This code snippet ought to pass QT + RT, but it fails.”

If someone were to provide a zipped up copy of an entire game that fails RT, I can investigate that, too, but I strongly suspect that the “line visited too many times” bug that @ArchivistAlpha096 reported is not the same bug.

2 Likes

I’m a bit swamped today and tomorrow, but I’ll see if I can create (or recreate) a small script snippet based on my codex script for Patchwerks.

If anyone else wishes to try, that would be appreciated as well.

1 Like

I got the called to many times error fixed, seems it didn’t like me putting down, for example:

*label d_door
*label d_door2
*label d_door3

Now I just need to figure out how phonecall is different from the other text files, as when I try the quicktest, it keeps saying that it can’t open phonecall.text, and as I never used either quicktest or randomtest before as my old computer had issues with it, I don’t know how to start fixing this at the moment.
You’d think that having lables with 3 or 4 or ETC tacked onto the end, although maybee not ETC but at this point I just accepted that sometimes, things that should work don’t, and finding ways around it is easier then trying to smash my head into the fact that even though it should work without issue, it doesn’t.

This topic was automatically closed 24 hours after the last reply. If you want to reopen your WiP, contact the moderators.