Dashingdon -- recursion error?

Second post within an hour about uploading my demo oof, i am very bad at this apparently!

Anyway, dashingdons been giving me a ‘too much recursion’ error every time i try to play the game i uploaded there. It refuses to load anything at all, just jumps straight to the error. The game works just fine in CSIDE, no errors and passes quick test and random test.

I heard it could be caused by rand commands, but i only have one rand command in the entire game so far and it basically jumps between one value or the other [in essense, theres only 2 results from that single rand command.]

Ive been at this for hours and im kind of getting frustrated, im not sure if im uploading the files incorrectly or if its another issue with my code entirely . I would’ve liked to have the demo up by today but it doesn’t seem like thats possible currently.

If anyone could offer any work arounds for this I’d be so grateful

That doesn’t seem like a ChoiceScript error. It’s probably a problem with Dashingdon itself. Try reloading the page or using a different browser.

Hi Nax –

A couple of things can be going on here, and based on my experiences, here are a couple of things to try:

Dashingdon runs an older version of Choicescript than CSIDE, so something that once was a problem might have been fixed in the newer version.

  • You can upload your project to Moody, which is a hosting site set up like Dashingdon’s but with a newer version of Choice Script.

  • You can run the tests in the Choice Script virtual machine to make sure everything is working and then compile you game and upload a html file to the forum in your WiP original post

or, if you really have your heart set on using Dashingdon…

  • You can investigate if this recursion error is caused by too many visits to the same label. If this is the case, you can add additional labels (ex. label1, label2, label3, etc) to limit the calls to a maximum of three… (this is the solution that worked for me, prior to the fix.)

Of course, the recursion can be an infinite loop created involving something else entirely.

I would try uploading your demo to Moody, and see if you still get the recursion error on that hosting site.

Here is the link to Moody: https://cogdemos.ink/

. :revolving_hearts:


Thanks so much! I’ve been running myself bonkers trying to figure out what i was doing wrong. I’ll try all of these options for sure!

I never would’ve thought visiting a label too many times would be an issue either dang, ive got to check that out

That has been fixed in the version of Choice Script available in CSIDE and on Moody now. So, going forward, it will not matter how many times a label is called upon.

Alright, i uploaded it on moody but again – im getting the too much recursion error.

I played around a bit and noticed something interesting – i only get the recursion error when i upload my images (as scenes) [the process CSIDE does to reference images]

When i EXCLUDE the image (as scenes) and only have the other text files, i just get a 404 error.

Am i missing something about uploading from CSIDE to moody/dashingdon? Im so incredibly stumped, i compiled my game in firefox as an html and it worked perfectly, so i dont know what im doing wrong here

1 Like

Whoops seems i was right about images causing the recursion issues! I changed it around and now the game works perfectly on moody. Thanks for the help Eiwynn! Cheers

1 Like

So Moody/Dash effectively error on use of image scenes?

Yeah, seems like it!