[CSIDE] The ChoiceScript IDE (v1.3.3 Now Available — 05/09/2022)

I kind of had a back up available thankfully but if you click on “Convert all indentation to space” and then “Conveet all space to indentation” it just removes all the spaces and the if and the words below it become the same

1 Like

Just downloaded on my new computer and was unable to update to the latest version of CSIDEx64, see screen snip below.

Check your PMs :slight_smile:

I have a question, does CSIDE flag bad formatting outside of commands? It looks like it only catches ${this and @{this, but not $this, $this}, or {this}.

The current release has minimal syntax highlighting patterns that can help detect some mistakes, but it’s definitely not all encompassing. The version currently in development improves a lot in this area.


I hope you dont mind if i ask you another question, i thought it better to ask here than make a new topic. I’ve come across a bit of a problem. Using your solution worked perfectly, except for the fact that one of my variables seems to increase everytime i enter and exit the stat screen. Now, i’ve done some testing and noticed that it only happens when using CSIDE and not when running the game through a web app. Do you know if this is a known bug or if i’m doing something wrong?

1 Like

There was some cases where this little bug also happened in the compiled game as well. Its the famous “reroll” glitch.

I believe you can fix it by adding a command like a *page_break or a *goto just after the increment line but I may be wrong.

I moved your question to the CSIDE thread, so that @CJW or another can help figure out what is going on.

1 Like

I’m sorry if this is a stupid question but could you explain what you mean by ‘increment line’? I am pretty new to coding and not quite sure what that expression means. And thank you for taking the time to try and help.

1 Like

I don’t have anything to add here currently, it does sound like the reroll glitch to me (though should be equally present everywhere). “Increment line” here is referring to your *set command which is “incrementing” (posh word for increasing) your variable value.

1 Like

Thank you so much for taking the time to explain. It seems to have solved the issue.

I downloaded the version on the public download (which says 1.0.1) and sometimes when I open it it says failed to get update from server. Does that mean that I’m still operating on the old version of Choicescript? Is there a way to fix this error?

@Cloudy is it the same error shown here?

Yes it is.

I’ve invited you to a PM thread which has a workaround.

first of all I’m so ashamed I have to post something like this, but it happened overnight and now I don’t know what to do


This morning my CSIDE shortcut turned to this, I used CSIDE for years and this is the first time I got this, tried to uninstall - and - reinstall but the shortcut always like this no matter how many times I reinstall.

And this is the inside of CSIDE folder:

is there any missing file? please help, thank you

It looks the main application binary (ChoiceScript IDE.exe) is missing. My best guess is that an antivirus software package has quarantined it? That’s the only explanation I can think of that would not be fixed by a reinstall.

I’ve just spent my entire morning working on fixing my laptop after I woke up to a looping blue screen of death – so unfortunately I had to completely wipe it for a factory reset.

Thankfully, I had a lot of my documents saved onto a flash drive so I didn’t lose too much. Unfortunately, I’ve run into some issues while trying to re-download CSIDE. After downloading and opening it, the following displays:

I’ve tried deleting all files and redownloading, but that hasn’t helped. The only way for me to close out of this tab is through Task Manager, as it’s otherwise unresponsive.

Thanks in advance for any help!

Try updating CSIDE manually.

Download this file (v1.3.3):

Then rename it ‘package.nw’. Note the extension must change; make sure it hasn’t been renamed ‘package.nw.zip’. Then replace the file with the same name in the CSIDE installation directory.


Hi all, just cross posting here. I’ve been having some compiling issues with CSIDE that I haven’t encountered before. Does anyone know what the issue is? Thanks.