CSIDE play test No bug, but Dashingdon play test bug?

As the title says, my testers are the only ones getting this bug:


But if I play test using the CSIDE I don’t run into this error.

I went in checked to see if there was a bug on my end in CSIDE but there was no bug, so I uploaded the .txt files. When I go to play it myself in Dashingdon I still get the same error they do.

So does anyone have any idea what’s happening? Do they need to clear their browser cache? Or do I need to give them a new link of the game?

Startup .txt file content

*create whisper_xp 0
*create enthrall_xp 0
*create sight_xp 0
*create summon_xp 0
*create siphon_xp 0

Hub .txt file where this error is supposedly?

    *selectable_if (((whisper < 4) and (xp >= whisper_xp)) and (mana >= 1)) #Whisper: ${whisper_xp} xp.
        *set whisper +1
        *set xp - (whisper_xp)
        *goto necromancy_home
    *selectable_if (((enthrall < 4) and (xp >= enthrall_xp)) and (mana >= 1)) #Enthrall: ${enthrall_xp} xp.
        *set enthrall +1
        *set xp - (enthrall_xp)
        *goto necromancy_home
    *selectable_if (((sight < 4) and (xp >= sight_xp)) and (mana >= 1)) #Sight: ${sight_xp} xp.
        *set sight +1
        *set xp - (sight_xp)
        *goto necromancy_home
    *selectable_if (((summon < 4) and (xp >= summon_xp)) and (mana >= 1)) #Summon: ${summon_xp} xp.
        *set summon +1
        *set xp - (summon_xp)
        *goto necromancy_home
    *selectable_if  (((siphon < 4) and (xp >= siphon_xp)) and (mana >= 1)) #Siphon: ${siphon_xp} xp.
        *set siphon +1
        *set xp - (siphon_xp)
        *goto necromancy_home
    *selectable_if ((mana < 5) and (exhaustion = 0)) #Closing my eyes, I focus inward and replenish my mana.
        *set mana 5
    #That's it for today.
        *goto overlook

*label xp_cost
*set intelligence_xp ((intelligence+2)*2)
*set persuasion_xp ((persuasion+2)*2)
*set observation_xp ((observation+2)*2)
*set accuracy_xp ((accuracy+2)*2)
*set athleticism_xp ((athleticism+2)*2)

*set whisper_xp ((whisper+1)*3)
*set enthrall_xp ((enthrall+1)*3)
*set sight_xp ((sight+1)*3)
*set summon_xp ((summon+1)*3)
*set siphon_xp ((siphon+1)*3)

You can try to peek at your hosted code if you know the how. I suspect dashingdon somehow doesn’t update that particular “redism” scene file.

Otherwise, I’ll summon @dashingdon here in case this is something happening server-wide.

1 Like

I did see that handy feature!

I looked at the code in dashingdon and it looked identical to code in CSIDE.

What was odd was the error was saying line 402 but that variable was located on line 403.

I play tested via DashingDon just now and there’s no more error message which makes me think it’s just a cache/browser related set back.

1 Like