*create throws an error for a text variable?


#1

I wanted to start my game with something rather simple. But whenever I try to use any text variable, I get an “invalid expression, couldn’t extract another token” error:

*create power 1
*create fame 0
*create followers 0
*create name “unnamed”

Results in:

startup line 10: Invalid expression, couldn’t extract another token: “unnamed”

If I use single quotes, I get the same error. When I use no quotes around “unnamed” I get a different error:

startup line 10: Invalid create instruction, value must be a a number, true/false, or a quoted string: name unnamed

Hopefully this is an easy issue to troubleshoot?


#2

You used ˝“ instead “” the correct ones *create name “unnamed”


#3

Gah!!! It’s the damned auto-substitution in my wordprocessor. Die auto-substitution, die! :smiley:

Edit: and now it works. :slight_smile:


#4

Mara’s advice NEVER code in a text processor please use a text editor made for coding there are tons free word office eats spaces and dont count code lines.


#5

Totally understand. And, for your heart’s peace, I am not using MS Word. :slight_smile:


#6

Thanks when I started coding I haven’t a proper text editor. So notepad eat my spaces and mixture hours of working I had nightmares with spaces and tabs :((