Code cannot parse the line after selectable_if

Currently writing a scene in my story, and for some reason I cannot get past this one part? Dashingdon cannot load past it and it keeps giving me this error message:
Screenshot (855)
I’ve tried a whole bunch of different fixes, can someone help me out here?

Here’s what my code currently looks like.

   *disable_reuse *selectable_if (Fergie > 15) #Introduce Fergie

     Words written here

Have you tried

  *disable_reuse *selectable_if (Fergie > 15)

Caveat: you can do that with *if, but I don’t know if it’s the same for *selectable_if, so this may not help you!

I would probably also move *disable_reuse to before the *choice

If that doesn’t work, are you sure the variable is viable? I.e. is it spelled correctly (in the correct case), and is the variable definitely numerical?

1 Like

i vaguely remember that

   *selectable_if (var) *disable_reuse #option

in that order might work?

Hm, in my experience it works if *disable_reuse is placed before *selectable_if. Does an enter between the choice and the text (even though it’s on the correct indent) affect things?

might also be the space between the > and the 15 that’s hiccupping

I have just copied your code, and added some extra bits to create the variable and give a second option, and it works fine in CSIDE for me:

*create Fergie 16
*label Choice2
    *disable_reuse *selectable_if (Fergie > 15) #Introduce Fergie
        Words written here
        *goto Choice2
    #Do nothing

If you copy and use this code above, does it work for you?


I have a space around those symbols, so that’s not it.

I have this one set up and it seems to work!!

This topic was automatically closed 24 hours after the last reply. If you want to reopen your WiP, contact the moderators.