Choice Script Changes To Run Tests With Firefox ver 68 ( See Post 12 & 31)

Would ChoiceScript work without hassle if you run the game on localhost server (and as such, access it via http)?

Yes. That’s what the run-server.bat and serve.command tools do.


That’s what I’ve done for the time being. Just bear in mind, the longer it stays downgraded for, the more security risks that could potentially pop up so may need to consider using a different web browser for general internet stuff.

Speaking personally, I don’t recommend downgrading Firefox. I think if you try the new run-server.bat and/or serve.command stuff, it will work, and you’ll even prefer it to the old way, because you can use any browser you like.


Absolutely. For me, personally, I only use Firefox for testing, so I could keep it downgraded for years and it won’t matter to me at all. Of course other folks’ mileage may vary.

I’ll try out Dan’s new way too at some point.


My issue with trying to use run-server .bat is that it kept saying “can’t locate system 32” or something like that. :flushed:

1 Like

I’m having trouble with - overnight Firefox has updated and this morning when I test the game it says Cannot load scenes
I’m really confused how I can test the game now? I don’t mean quicktest and random test as I use CSIDE for that, but more basically just check what I have written and so on?
Chrome doesn’t worj either

I downgraded to previous version, disabled auto updates and this seems ok

What a strssful start to the day!

Sorry you are experiencing difficulties.

The following should help:

Refer to the post for the entire procedure to follow.

Thank you for your help, I had a panic attack that it was all lost -apologies
I have downgraded firefox to where it was before, turned off updates and it is working now.
I do all my testing in CSIDE and use firefox to see the game so I should be ok barring any other complication
I will calm down a bit now before doing anything else


I have my firefox downgraded and in a external hard drive so no way in hell connects to the internet. As I only plugin it offline. I still code on phone just I can’t test it anymore having to wait to be in pc range.


Throwing it out there: for people who insist on downgrading Firefox, you can instead download an old portable version:
Grab any v67. Install it wherever you want, then disable automatic update in options.

It can work purely as a CS-only browser. It doesn’t share any data with the main up-to-date Firefox, you can run both browsers in tandem and you can store it just about anywhere (usb stick, external/internal drive, etc)

Do not surf web with portable version and you’d be set. Or better yet block its access to internet in your firewall.


Yesterday morning i was happily working on a new Choicescript game.
Today, firefox says it can’t find “startup.txt”.

The files are there.

So i went back and tried to run my old CS games, they don’t work either. Same error, but the files are all still there.firefox%20error

Please help!

Try on chrome to see

it never works on chrome, that’s why i use firefox.

I’ve also tried restarting, and moving files around. even updated firefox.

I wondered if maybe this had happened to anyone else?

1 Like

Maybe, i don’t know. I have never used Firefox for that. I only use chrome and it always works for me. Well, actually in Chrome i can’t create Dashingdon games in my dashboard (I don’t know why) but it’s the only bug i have ever had. I use puffin browser to create a game whenever i want to and then go back using chrome.

I moved your question to this thread; the instructions upthread should help answer your question.

When I try to open my game by using fire fox, I get a message that says, “Please “upload” choice scrip” and says that I need to grant permission to upload the choicescript folder containing index.html. I did what I thought it was asking and a few other things but nothing seems to work… It only says that it couldn’t find the folder. I never used to have this problem. What do I do?

1 Like

I’m having issues with both my random test and my quick test, though two different issues.

For quick test, every time I try running it, I get:
ERROR: couldn’t open web/mygame/scenes/startup.txt

For random test, the test starts, but I just get a white screen with nothing happening.
That could just be shoddy internet, but I’m doubtful considering that to test, I left it running with a single iteration for 6 hours when I went to work, and came home to the same white screen with no progress made.
Funnily enough, I can still kind of use Random Test if I use the randomtest.bat file in the docs, which produces a notepad called randomtest-output. But it only gives me one test at a time, and I’d prefer something a bit more efficient than that.

I’ve tried running both with Internet Explorer, Chrome, and Firefox.

I’m having the same issue with quicktest

I’m having the same issue while I could just get other people to test it I would rather use quicktest or random test :hushed: