Can anyone spot the error?


#1

Although it passes QuickTest, for some reason Unnatural is failing a RandomTest at this particular point…

In Episode Six you have this choice (which for some reason RandomTest is getting the “no more choices” error)


*choice
  *if ((vampireone) and (vampiretwo = false))
    #"Fangs for the memory." 
      *goto fangs
    
  *if ((werewolfone) and (werewolftwo = false))
    #"Cure."
      *goto pack
    
  *if (((gargoyleone) or (gargoyletwo)) and (gargoylethree = false))
    #"Witch way?"
      *goto rock

Now in Episode Three you have a choice of doing “By Tooth and Claw” (which sets werewolfone true) or “Creepy Statues” (which sets gargoyleone true) then you can either do the case you didn’t do or “SOS” (which sets vampireone true).

So by the end of Episode Three you should have either of these combinations…

werewolfone and vampireone
werewolfone and gargoyleone
gargoyleone and vampireone

So 2 out of those 3 choices should appear in-game but randomtest found a path which doesn’t (even though one of the choices had it doing “SOS”) but only “Cure” appeared. No code sets vampireone to false inbetween episodes 4-6 so I’m getting a bit annoyed.

Hopefully someone will spot a blatant basic error that I’m just too knackered to spot!


#2

That part of the code seems to work fine (with preset combos), so I’d presume that somewhere else the variables are being changed?

Have your tried an inline syntax?
*if ((vampireone) and (vampiretwo = false))# "Fangs for the memory"


#3

@CJW

just tried that and the error still shows up. I’ll have to look at the variables again.

edit: Just double checked the stats and they aren’t being changed where they shouldn’t be. Yet the error only comes up with random test and not quick test, this is very odd.


#4

AFAIK RandomTest ‘cheats’ by creating a copy of itself, but with one (and only one) variable set differently, and thus can get into situations that the player couldn’t get into; it may be possible that this is happening here.


#5

I followed the choices but only cure was visible even though I did the SOS mission.

I pm’d Jason and he said it would have to pass randomtest so I need to fix this.


#6

@Nocturnal_Stillness
This is a good example of a situation in which I think the IDE’s Variable Tracker could prove useful! :slight_smile:


#7

I can’t spot the error either.

Can you just add an elseif with a “you have reached an unexpected error?” or something? I seem to recall spotting a few of those in Zombie Exodus’s code. Or if that’s not allowed can you just put in an else with finish or something? Or will that not work in the choice?


#8

@CJW

Thats a good point I’ll copy and paste all the files into your ide and we can see if that shows up what is causing the error.

@FairyGodfeather

this particular choice depends on cases you’ve done previously in Episode 3

Doing “By Tooth and Claw” should let you do “Cure”
Doing “Creepy Statues” and/or “Between a rock and a hard place” should let you do “Witch Way”
Doing “SOS” should let you do “Fangs for the Memory”

I’m going to run it through the IDE and see what it shows up.


#9

This is odd, for some reason dying during episode 6 seems to set the stats back to neutral which would explain why the error appears, but I died earlier in the game and it retained the stats. I’ll look into this further.


#10

Does the game set vampiretwo, werewolftwo or gargoylethree to ‘true’ anywhere?


#11

After you do that specific case.

edit: just want to cry I’ve started changing the code to fix the error now my pc froze and i did manage to save it but now i reloaded it all the text has been replaced by the word NULL repeatedly Grr looks like I’m reloading an earlier version of the file.

2nd edit: I actually managed to salvage the file ok. phew.


#12

I’ve got past that error now going through the rest of the random test last time I got an error it was seed 119 (not sure how many seeds there should be in total?)