Unable to see randomtest line coverage statistics

I am officially stuck.

I’m currently editing my new game, Wraiths of SENTINEL (formerly called The Darkling Watchers, and a few other things besides), and there are significant balance issues. I’m trying to use the randomtest to check line coverage statistics, to address that.

But any time I check that option in the randomtest, the test freezes immediately before its last seed, and remains uncompleted.

I’ve tried running the randomtest in a range of browsers; this hasn’t helped. As suggested elsewhere in the forum, I’ve downgraded Firefox to version 67.0. This hasn’t helped either.

I’ve run the randomtest in the command line (and Powershell), and this DOES work. The problem here is that it’s a long game, and this method doesn’t allow you to scroll back infinitely. Even when I set the line buffer to maximum (9999 lines), this still only allows me to see the last quarter or so of my game; everything before that is lost to unscrollable oblivion.

So, I’m now out of ideas. The only possibility I have in mind is to cut my game up, and run the randomtest on, say, the first two chapters, then the first four, then the first six, and so on. And that seems… unnecessarily labor-intensive.

Does anybody have any advice on how I can see the line coverage statistics? Pretty please?

Until then, I’m going to grumpily edit various typos and unwanted loops.

(By the way, a few people have been playtesting the game so far… Thanks immensely; your feedback is enormously useful! I’m working as fast as I can to put it all into an updated version of the game.)


I’ve never done it but a quick Google suggests you can save the output from powershell to a file. I didn’t read any further to see if it is a viable option though.

1 Like

I’ve hit this problem too, does the solution in this thread help? It worked when I tried recently.

Solved! Woo-hoo! As @Sinnie mentioned, it’s possible to run the randomtest in the command line (or Powershell), and save the output to a .txt file. With a little experimentation, that’s worked for me.

@HannahPS I did see that thread earlier, but wasn’t sure how to open the node.js prompt… After about three hours of playing around with this, however, I think I’ve leveled up my computer skillz; I could probably manage it, now.

Thanks for the replies, and the help!