Quicktest unhappy with bolding text


#1

I’ve run into a little problem:

When doing quicktest, it tells me that this line causes an error

Primary Class: @{(special_class_p != "none") [b]$!{special_class_p}[/b]| $!{primaryclass_parent}}

due to the /-operator at the [/b]
Manual testing however works perfectly fine.
Is this normal?


#2
*title test
*author test

*create special_class_p "hello"

Primary Class: @{(special_class_p != "none") [b]$!{special_class_p}[/b]| $!{primaryclass_parent}}

startup
executing
startup line 7: WARNING there is no next scene; *finish will end game. Use *ending instead.
QUICKTEST PASSED


#3

I think quicktest hates me.

I tried making both possibilities bold

Primary Class: @{(special_class_p != "none") [b]$!{special_class_p}[/b]| [b]$!{primaryclass_parent}[/b]}

and first it complained, then it didn’t >_>


#4

Have you tried testing it with a bunch of simple *if statements to see if you still get the quicktest error?


#5

Yeah…
It’s really weird. As said, manual testing works flawlessly. (though I need to shove some line_breaks around)