Non-existent variable error, need help


#1

Hello! I must ask for help once more!
I do not know what is the issue here, I rechecked spelling and the startup, can’t seem to find the problem. I hope you can help.


I get this random error I’ve never gotten before:
chapter2 line 1336: Non-existent variable 'owner_info’
Help?
:smiley:


#2

Did you *create owner_info false in your startup file?


#3

Obviously. You take me for a newbie sire!
Jk.
Yeah, I did that.
That’s the thing about it being weird.
The variable’s there. I think it has something to do with *selectable_if command.
:smiley:


#4

And is it definitely a Boolean (i.e. true or false, without any quotation marks)? :stuck_out_tongue_winking_eye:


#5

Yeah. No quotation marks. True/false.
:smiley:


#6

Think this might be one of those errors that have no explanation nor solution at all.


#7

Can you copy-paste the code with the *create variable from startup so we could see? I believe you, that it’s there, I just think sometimes looking at the code in question can lead to useful ideas or suggestions.

Also occasionally, when I’ve had odd errors, deleting both the lines in question and then re-typing them has had good results for me…


#8

Maybe if you shared what your startup looks like to see if you missed something?

Though I’m sure it’s fine, it can’t hurt. I swear I sometimes get the most random errors and reworking the scene usually fixes it in some way. Maybe create a new variable for owner_info and use it instead. :stuck_out_tongue:


#9

Here ya go.
Anything else you need?
:smiley:
It’s very…hmm, an odd error.


#10

Did so, I’m afraid. It didn’t work.
:smiley:


#11

Sorry, I mean, can you copy-paste the actual text instead of screen shots? And you’ve tried deleting both lines and re-typing them? You could also try clearing your cache so you’re sure you’re running the latest version of all your files, then, perhaps?


#12

Sorry if this sounds stupid, but do you want the entire code of startup?
:smiley:


#13

Sure? You can always put it under a cut with [details=startup] [/details]. (I’m sure I’m the one who sounds stupid, fishing about for a solution to a very odd error with you all, so I wouldn’t worry about sounding silly or anything. ;p )


#14

Brace yourself.
:smiley:

*create name “Unknown”
*create class “Unknown”
*create house “Unknown”
*create gender “male”
*create he “he”
*create gender “female”
*create him “him”
*create his “his”
*create man “man”
*create sir “sir”
*create mr “Mr.”
*create dalkan_relationship 30
*create zerphis_relationship 20
*create archers 0
*create huscarls 0
*create knights 0
*create mages 0
*create emperor_relationship 10
*create qolen_relationship 30
*create elena_relationship 10
*create tasal_relationship 10
*create william_relationship 30
*create aeyron_relationship 20
*create enzo_relationship 10
*create tars_relationship 20
*create renown 5
*create gold 0
*create titanium_sword false
*create knight “Knight: You rely on your strength, on your mount and value honor above all.”
*create hunter “Hunter: You rely on your sharp eye and settle most of the deals with a well placed arrow.”
*create assassin “Assassin: You rely on your agility and use intrigue to solve matters.”
*create mage “Mage: You rely on your wisdom and use spells to balance the odds.”
*create warhawk “Warhawk: You rely on your ironflesh, you settle deals with violence and have a bad temper.”
*create deathbringer “Deathbringer: You rely on dark magic and willpower, intimidation ensures that you’re always safe.”
*create mercenary “Mercenary Captain: You rely on your men and place their needs above all, you use leadership.”
*create scholar “Scholar: You rely on your intelligence, you prefer to settle deals with diplomacy.”
*create men_preference false
*create both false
*create none false
*create women_preference false
*create inspired_troops false
*create claim false
*create ladders false
*create iron_sword false
*create iron_armor false
*create horse false
*create bow false
*create leather_armor false
*create assassin_robes false
*create throwing_knives false
*create dagger false
*create magical_staff false
*create war false
*create warfavor 10
*create magical_robes false
*create magical_spellbook false
*create iron_warhammer false
*create aeyron_alliance false
*create hardened_iron false
*create death_bringer false
*create iron_greatsword false
*create iron_pike false
*create book false
*create shortsword false
*create slace_armor false
*create mastercraft_bow false
*create mastercraft_sword false
*create owner_info false
*create vassal false
*create knights 0
*create huscarls 0
*create archers 0
*create mages 0
*create leadership 30
*create strength 30
*create willpower 30
*create intelligence 30
*create agility 30
*create magic 30
*create perception 30
*create endurance 30
*create health 100
*create armor 0
*achievement first_blood visible 10 First Blood
You slew the great beast by taking the minimal damage possible!
*achievement zerphis visible 20 Friends In High Places
Zerphis, the divine of hate thinks highly of you!
*achievement battle visible 20 A Commando
Win the battle for Castle Hearth!
*achievement william visible 10 Romance: William
Start a romance with William Rivaldog.
*achievement sword visible 20 The Sword Of Justice
Purchase a legendary sword, “The Eclipse”.
*achievement enzo visible 10 Strength Of Will
Meet Enzo Fransez, a soulguard.
*achievement tasal visible 20 Best Friends
Befriend Tasal Masaji.
*achievement bigbattle visible 30 The Challenger
In the battle at the ruins of the Forgotten, challenge 2 lords in battle and win!
*achievement fighter visible 30 Champion Of The Realm
Win the tournament of the realm.
*achievement aeyron visible 30 Through Unity, There is power
Befriend the Aeyron bloodline.
*achievement duelmaster visible 10 Duel of the century
Have a duel with the furious blademaster in the enemy camp.
*achievement ally visible 40 A Leader
Unite every region to fight against the Emperor.
*achievement legend visible 50 A Legend
Defeat the Emperor and his forces.
Edit: You asked for it.
:smiley:


#15

Well, I’ve no idea what your problem is, but you don’t need to create gender twice…


#16

COUGH
Shh.
Every genius is crazy in a way.
:smiley:


#17

Also you’ll want to indent the achievement texts or you’ll have an error, like so:

So, I threw your code into CSIDE and typed up the snippet from your main scene, like so:

And it worked perfectly.

Are you running the game in a browser when you get the error?


#18

By the way, do you get this error runnning quicktest/randomtest or playing through the game? Apparently quicktest can give weird errors even if it is fine.

(Aaand ninja’d by @Fiogan once again! Haha!)


#19

Welp, I just click “index” and off with you.
:smiley:
(Yes, I use firefox).


#20

Try saving all your files, closing all your files, opening up a private browser window, and running your game? I can’t help wondering if, for some reason, it’s reading an older version of the startup file.