I can't restore games I purchased on the Google Play Store

I’ve purchased a handful of COG/HG games in my time. These purchases were from the individual apps and not the omnibus.

I downloaded the omnibus today and wanted to see how it looked. I tried restoring [A Mage Reborn] which I purchased yesterday and it didn’t let me.

The only one that shows up for restoration is [Jolly Good]. Games like [Samurai Hyuga 4] or [Fallen Hero: Rebirth] don’t show up.

Does the restore functionality not recognize Google Play Store purchases?


Do you have the app installed as well? Based from my experience, having the standalone app installed and restoring it with app option worked most of the time. Otherwise, please email support@choiceofgames.com for further help. CoG/HG staff will contact you at their earliest convenience.

1 Like

I do have the standalone version of every game I mentioned in the OP currently on my device. But there are other games I purchased which I don’t have on my phone that didn’t show up either.

Is this the kind of error you’ve experience? Try sending an email either on the email I posted above or the email found on the error menu like below) so that a staff could help you.

It’s not that. The omnibus routed me to the site and when I entered my credentials, it gave me this.
Screen Shot 2022-08-06 at 12.22.10 PM

I know I purchased more than this game. I just don’t know why they aren’t showing up.

I believe if you have the google play purchase receipts, email the receipts to support@choiceofgames.com to get them to add games purchased as individual apps to your choiceofgames account/omnibus.

More info on transferring purchases between platforms can be found: Transferring Purchases - Choice of Games LLC

Edit: Not 100% on exactly which method should be used for individual android apps > omnibus but the person who answers support emails is super helpful with figuring out what to do


Hello, I would advise you to send an email to their support to help you sort this out. Make sure to send screenshots of the receipts. It’s the first time I’ve seen that error. I apologize if I can’t help much.