CSIDE bug (or something...I'm not exactly sure)


I found something while working in CSIDE this morning and thought I might share to see if this was a bug or something.

The thing

So I was working on a story and I wanted to use only opposed pair stats as the skills. So I go on my usuala way and create the opposed pairs;

I think I got that code right, mostly. It isn’t the problem however.

It starts when I run the game inside the CSIDE;

As you can see, in each of the blocks, the last opposed pair’s right sided word just vanished. Poof.
Just like that.

After a bit brainstorming, I was able to fix it, although in a very unorthodox way;

I added a placeholder stat in percentile in the first block and moved the opposed pair up in the second block.

And the funny thing is, it worked;

That is, if you can ignore that there is a stat literally named Placeholder in your stats screen.

Some background info; I run a Windows 10 rig which was updated just before I downloaded CSIDE from github this morning. And no, Notepad doesn’t have this problem.

So my question is; is it a bug? Or is it some cside feature that i didn’t know?

PS:Sorry for my poor english. I am not a native english speaker, as you can see.

Also, sorry for the shaky images. It’s the best I can do regarding the circumstances.

Thanks in advance.

A post was merged into an existing topic: [CSIDE] The ChoiceScript IDE (v1.3.0 Now Available — 18/06/2019)