Can't find variable Alertify


#1

Can’t find variable Alertify

Not sure about this one. I’ve gotten it twice now:

  • Once at the very end of a playthrough.

  • Once when using an *input_number

Any ideas?

Oh, and I have no such variable or call upon any such variable, telling me that this is a Choice Script thing.


#2

I would guess that you need a new copy of the CS files.


#3

I think I have the most up to date. Hmmm… I’ll reload anyway, just in case.


#4

It WAS the same version I’m running. But maybe my Dropbox version was older? Updated both. Hopefully that fixes it. Thanks @Samuel_H_Young!


#5

Alertify is the JS library used to display the dialog boxes (restart? Yes/no etc).
So I’d imagine as Samuel says you need to redownload the CS core.


#6

Crap, still having Alertify troubles. I have the most up to date files. Two spots that I’ve noticed:

  1. When I use the *achieve command. Should I be able to use it without anything happening?

  2. During a *input_number I put in 1000 and it gave me alertify troubles.

I’d like to solve this before Beta Testing. Any ideas?


#7

Solved #2. I’ll bet it’s an iOS thing, right? I get a nice little window saying that I have exceeded the amount I tried to enter, when I’m on the computer, but since that’s Java, that won’t work on an iPad, right? Thus, an error.

Back to #1, may I use the *achieve command, or should I be leaving it out until release?


#8

It should work just fine on iPad, even if the popup doesn’t, it shouldn’t “error” or crash - just stop you proceeding, until you pick an acceptable number.

You should definitely be OK to use the *achieve command.


#9

And yet both are distinctly crashing despite having the most up to date Choicescript. I changed the *achieve to comments and put a ridiculously high max on the *input_number and checked the max myself, so it’s no longer crashing for now.


#10

Are you developing on an iPad? Does it work ok on a desktop?


#11

I use both, but I like to test on the iPad. Yes, it works on the PC, but on on the iPad, which is why I blamed Java. :slight_smile:


#12

Choicescript is written in JavaScript, which is very different from Java (despite the name). There is a Java branch of Choicescript but I’m pretty sure that’s only used for the Kindle Fire versions.
This might be a bug, annoyingly I don’t have an iPad to confirm or test it on.