Bug with 'Non-Existent Variable'

Originally this topic was for something else but I fixed it, so I figured it would be better to just repurpose this one since I had another and more important issue anyway.

I was wondering if anyone could give a look to let me know what in the everloving hecc is causing some players to have a bug where they have ‘Non-Existent Variable’ at Line 1223 in Chapter 1 and I am unsure as to the cause.

I can’t really directly link the problem, so I hope you don’t mind me just sending the scenes.

The variable the game claims it is looking for is ‘chapter1_teashop’ but I can’t find a single mention of that variable at all so I am pretty confused as to the problem.

1 Like

image
I would love to help but since I changed SO I see some characters messed up.

Have you tried running randomtest a good bunch of times to see if you can catch the error?

Sometimes if you don’t clear the cache the browser can use older files stored locally and the game crashes because of that. that can happen to some players even if you already updated the dashingdon files.

The characters are not messed up, they are codes for specialized ‘emoticons.’

I just tested 10000 seeds and no issue on the local files.

Is this an issue I can fix or is this just from old saved media from the player side?

Response to @Loopylazy72 :
No, I most certainly did not write teashop, I checked all the files. Teashop is written a single time, in the very choice you highlighted. Nowhere else is it written. Thank you for the help by the way, I am unsure exactly what the problem even is. I can’t replicate the issue and randomtest has no problems.

*if (prologue_gaozhi_travel = true) and (chapter1_teahouse = true)
  Luckily, your own familiarity provides you with some insight about where to go, provided that the city has not significantly changed how it is districted since the last time you had visited. 

  *fake_choice
    #Take $!{min} to your favourite teashop...
      *comment skip!
    #Let $!{min} decide where to go... @{visualind [b][⇑M][/b]|}
      *set Maff + 1
      *set chapter1_teahouse false
      It was not as if you had much of a preference where you were going, anyway, so you figured that letting Min pick would give you more insight about the stranger in your midst.

In this bit of code here, im not sure what line it’s on, i noticed variables named, ${chapter1_teahouse}.

Maybe just double check you wrote teahouse and not teashop?

@Phenrex would you be able to tell us exactly where line 1223 is?

If it happens to all the players there’s something wrong, but if it only happens to a handful of them I think the most probable issue is their browser cache. Nothing you can solve other than letting them know.

1 Like

Naturally!

Line 1223 is this:

More importantly, $!{Min} is looking at you expectantly, gesturing you forward away from the plaza. You looked over and found ${mhim} eyeing the dancers, an emotion you couldn't quite decipher written on ${mhis} face before ${mhe} shifts to guide you away. Part of you felt it was undignified for ${mhim} to try to lead you away like a mislead sheep. Tempting as it was to promptly tell ${mhim} your mind, it was only the growing reminder of the purpose you are here that keeps your tongue tied and your feet moving forwards.

Note this: The bug predates my update to the stats and chapter, and is the same line despite the fact I added dozens if not hundreds of lines into Chapter 1 before Line 1223.

Does that mean this has to be client side? Because otherwise wouldn’t the line have changed when I added more code?

I have read that line so many times now that I think I could recite it from memory in a few days time. Nothing seems to be wrong with it, it seems to be a completely normal text line. Not sure what’s causing this teashop kerfuffle, considering the actual scene is sevreral lines below.

would you be able to provide a screenshot of the error message?

This is from one of the players (do I need to test the game on my own phone to see the issue?):

I think this has to be a cache issue? I have tried to replicate it on mobile but could not.

I’m sorry but this is literally all I could think of, if this isn’t it then you will require an actual immortal to figure this out.

*if (prologue_gaozhi_travel = false)
  Recognizing that you are in foreign territory, you consider whether or not it would be best to ask $!{min} whether ${mhe} knew of a place where discretion was always a priority.

in this bit of code after the choice which the error appeared at, there is an *if statement.

However, i noticed there is not an alternative *if where prolougue_gaozhi_travel = true, or an *else statement.

unless it is physically impossible to make that variable true, that is a problem. But if that’s the case, it makes me question why the variable is needed in the first place?

Still that doesn’t explain cs litterally making up a new variable, but alas, this is as far as my intuition could carry me.

Hoping against hope it was just a chache issue :upside_down_face:

There is an *if prologue_gaozhi_travel = true variation, it’s the big swath offering going to the teahouse (since you would only know where to go if you traveled to gaozhi often)

@Loopylazy72

it’ll be a cache issue then, or your game is infested with a demon, one that likes tea.

The only demon allowed near my writing is me… :smiling_imp:

1 Like

it’ll be a cache issue then, or your game is infested with a demon, one that likes tea.

Players who save with the sm_init command on Dashingdon before an update and then try to resume their save after you’ve added more variables to startup.txt won’t have the updated variables in their game, because their saved game never created those variables. That’s probably what’s going on here. Happened to me too. I usually tell people to start completely from fresh after a major update, even though it sucks.

1 Like

This topic was automatically closed 24 hours after the last reply. If you want to reopen your WiP, contact the moderators.