Bad Label Error WONT GO AWAY

I’m not entirely sure, I tried playing through the other choices and they keep stopping me for different reasons. I’ll come back to you once I’ve finished the rest of the scene if the issue is still occurring. Thank you!

1 Like

Always have an “ending” command at the end of your work, so the game can logically progress to its end. (have an *label ending on the line before it, so your code flows there.

http://choicescriptdev.wikia.com/wiki/Ending

*if(MetFrost=false)
         "What's your name? You ask. "Frost," She replies. "And you?" "${firstname}" You respond. "Nice to meet you."
         *set MetFrost true
         *gotointerview

It seems that goto interview is missing a space. Anyway do you have notepad++ or something? You could search for interview* in all your files to see if there is still some goto pointing to one.

1 Like

I’m using the version of notepad that my laptop came with, so i don’t know if it’s ++, but I have checked all of that file and found no other *goto interview*s, and since this is the only file where I use that label, I don’t think it would come up anywhere else.

You’ve double-checked that you uploaded the current version of the scene to Dashingdon, and then you’ve tried opening the game in a private browser window? Just to make sure it’s not a cache problem, with the browser ‘remembering’ an older version of the file.

Also, to answer your earlier question, how to clear the cache can vary, I think, depending on what you’re on. You can do it through your browser’s preferences, or in my case on Mac in Firefox I use command-shift-R—or using a private window does the same thing, no cache involved. (And sorry for the bit of a delay in responding.)

I have two tips that might help with debugging.

  1. Usually the errors will have the line number on them. Using that line number, you can go to the exact line of your file that you need to examine. Like, it probably won’t just say “bad label: interview*”, it will say “524 bad label: interview”. Use a text editor that displays line numbers so you can more easily to to the exact place in the file that is causing the problem. What is the exact and complete error message you get, including any number?

  2. I think it is easier to debug scenes locally, before trying to load them to dashingdon, because then you don’t have to worry that maybe the version you are editing is not quite the version that is running, due to a mistake in uploading. Do you get this same error when you run the game locally? (I mean, when you click on index.html and play the game on your computer.)