Invalid Indent error

I need help! I have been trying for hours to figure out how to fix the expected an option here not goto error and nothing has worked. It says there’s an error on line 20, but there’s no options or gotos on line 20 it’s just text. I tried adding a page break, I tried added goto_scene I tried adding a goto label, I tried indenting the gotos but they are on lines 80-81 or so not 20. This error is plaguing my game.

I’m having trouble with… Indent error

The error I’m getting is:… Line20 Invalid indent, expected #option not *goto

My code looks like this:


*goto_scene chp1nextdaymale

In what scene are you getting this error?

I have separate files for each personally meeting Tofuyu. It’s right after you meet him and he leaves. It won’t jump to the next scene.

Can you tell us in which file we meet him and where should the scene change? There’s a lot of text in the game and it’s difficult to figure out where exactly the error is happening.

1 Like

I’m assuming the error is in chp1nextdaymale.txt?

Just checking, are the last two options in this part indented right? Because when I look at it using Chrome’s text viewer there’s a few extra characters, but when I download the file it shows up normally.

Update: YES! That’s where the error is! I just need to try to fix it on mobile.

1 Like

I can’t copy all the codes on my tablet, But my code looks like this

I know those white marks mean it’s incorrect but idk how to fix it

You could retype the choices to fix the spaces. CSIDE has an option where you can turn on visible indentation–it might help with seeing the differences in indents.

For some reason those accented A’s only appear in ANSI encoding. They don’t show up in UTF+8. If you use Notepad++ to view the file, you can see the difference.

Sorry to hear that. Not sure if this will help, but recently someone asked if they could edit ChoiceScript on mobile, and there are a few suggestions on the wiki page. The error could have been caused by an app using different encoding types.

1 Like

My computer is broken so I only have mobile sadly till I can afford a new one that’s not going to die on me again. I’ll have to try to redo everything

1 Like

I use CSIDE on mobile browser on my tablets when I can as it does not work on my phone and gives me errors where there are none