ChoiceScript not storing user-input text variables


#1

Hello everyone,

I think I might have encountered a bug.

I’ve been working on my game for quite some time now. Yesterday I downloaded the last version of ChoiceScript from github and when I started testing the game I realised that when I tried to print a string variable, previously introduced by the player, nothing appeared.

I thought I had unwillingly changed something while updating to the lastest version, but then I pasted the same code to the ChoiceScript IDE (https://dl.dropboxusercontent.com/u/7840892/CJW/choicescript/tools/IDE/main.html) and it worked as usual!

I downloaded a new copy from github and tried the following on the startup scene:

*create name “”

What is your name?

*input_text name

*page_break

Hi ${name}

*finish

All I get is “Hi”. I also tried on iexplorer and got the same result (I’m using Firefox).

What do you make of it? I would really appreciate your help.

PS: The way I “updated” to the newer version: downloaded the new ChoiceScript folder and put the scenes I’ve written in the folder “scenes”.


#2

I’ve gotten something weird like this once, and when I upgraded to the latest version of Firefox, it started to work. Maybe that’s you’re problem?


#3

I get the same, so there does seem to be some sort of inconsistency here.


#4

@that1german Thank you for the swift reply! Just updated Firefox and the problem persists :frowning:


#5

@CJW Thank you! So is not just me then? Is there a way to report bugs?


#6

I think the best way is to just @dfabulich :smile:

Worth noting that it works if you provide a value to the create command (for e.g. *create name “John”) - but it seems to tag on an extra a for some reason, so it appears as “Johna” when printed o_O


#7

@CJW Yup, the string variables I create at startup do show (I was not aware of the extra A though).

By the way, it’s you who made the choicescript ide, right? Thank you very much sir!


What's going on?
#8

There was indeed a bug here, very recently introduced. I’ve just fixed it in the latest version of ChoiceScript up on Github.


#9

@dfabulich Thank you very much!


#10

@dfabulich Did this update break the Quicktest?

I’m now getting a Reference Error “window” not defined.


#11

Oops, yes it did. Fixed in the latest version.