The People's House (WIP) (UPDATED: 2/19/24) - Presidential Sim

I have! Right after Jackson tells me that the Senate is split 50/50, it doesn’t let me progress.

2 Likes
Screenshot of error

I keep getting this error.

2 Likes

@RFKramer
It seems that the problem is at the Chapter 4 midterm elections (regardless of the result) but it’s not present on your end.

Maybe the issue is with dashingdon? I’ll try it later today.

2 Likes

Hi all,

Apologies for the issues with coding here – my best guess is that this is an issue with DashingDon, the hosting site for the demo. I’ve run through the code several times and haven’t found any issues with my own testing.

I’ll keep looking through it and will try to set aside time to play through it myself to double check.

Thanks for bearing with me again while I try to sort this out! I’ll be doing some deeper digging tonight so expect another update from me later today or early tomorrow.

12 Likes

After a Unity playthrough (Rep POTUS, Dem VPOTUS, m. Richter) of the beta tester version of the game (which is the same as Patreon version), in Dashingdon, I did not see the bug that people are reporting here. I was able to progress through my midterm and avoid impeachment without issue, and was also able to see the beginning of Chapter 5. While there were some issues, there was nothing game-breaking or contradictory to my choices/playthrough. I also did another playthrough (Dem Party POTUS and VPOTUS, m. Walfort) and also had no issues. The international trip also differed between the playthroughs (Asia and WEurope). My Party playthrough had an affair (and was more corrupt/friendly with Bill), my Unity playthrough did not (and was almost completely upright). Although both my playthroughs ended up at Midterm 5 (Senate gain, House slight loss). The lower Midterm values should be checked over, I think.

@RFKramer One interesting thing I spotted: at the end of the chunk of chapter 5 in the Patreon/beta version, it goes to the epilogue introduction instead of to the “Play again” screen (after the epilogue introduction, it goes to “Play again”). Since I wasn’t impeached, I should not be seeing this epilogue at all.

Spouse name in stats screen


It just shows Spouse’s first name in their relationship meter. I think it should show their name as displayed under “Spouse”.

2 Likes

I keep on receiving this error everytime I reach this page.

2 Likes

I think this must be an issue with DashingDon, then.

I’ll try re-uploading the text later today to see if that fixes anything.

1 Like

Formal Writer’s Diary will be released next weekend (the 18th-19th), but I wanted to release a quick update:

I have been working quite hard on getting these issues with DashingDon sorted out. I’ve updated the version I have to the Public Demo link (in post #1) but have not been able to play through it yet. As such: If the public version of the demo is still not working, it is an issue with the hosting site and not with the game.

I’m thinking (if this is the case), the only way around it would be to create a new link to try uploading the public demo to. I am of course also open to any ideas if this has been encountered by someone in the past.

I have also been working towards writing additional scenes into Chapter 5, though these issues have understandably been taking up a bulk of my time.

Will keep you updated and have a full writer’s diary released next week!

Best,
R.F.

7 Likes

Saves seem to be broken in public version

2 Likes




3 Likes

Exactly my issue

2 Likes

Which version of the demo was this on? And were you trying to reload an older save or just start a new game?

There shouldn’t be any issues on my part – the save function is enabled across all versions of the demo, but I can try to see if there are potential solutions elsewhere.

2 Likes

Quick Coding Update #3

Hello again friends.

I recently came across this thread from 2016: Updating file issues at Dashingdon?

It seems to have a lot of the same issues that many people are running into now. While it’s from 2016, I figured I’d share it with you all to see if it fixes any of the issues while I’m trying things out.

In this thread, it’s suggested that you try either clearing your cache (this can usually be done by going to the settings function of your browser) or by opening the story in an incognito or private tab. It seems that copying and pasting the link into a private tab was the easiest workaround (according to this thread).

Once again, I apologize if this solution still doesn’t fix anything – at very least, it appears to be an issue with the cache and not something I’ve been doing horrendously wrong.

Thanks again for your patience and help,
R.F.

10 Likes

@RFKramer I know it’s a silly request, but could you add coffe?

3 Likes

Thank you so much for your timely response! The version of the Demo is from the first post, and I’m trying to start a new a game as I can’t access my older saves.

Edit: I’ve deleted my cache, and have opened the Public Demo in a private tab. Maybe it’s the browser I’m using? (I’m using Opera on Mobile)

3 Likes

Of course!

Still not working I assume?

If that’s the case, maybe I should also try to re-upload the files in an incognito browser as well after clearing my cache to be sure. I’ll try doing that when I’m out of work today and try playing through it myself to check if I have the time.

My last resort is to create another save; which isn’t ideal as I’d need to name it something different and would lose the lovely counter of clicks on it (currently over 11k which is insane!)

3 Likes

With every demo update, old saves made in previous versions will get glitchy and become unusable. This is normal.

As for the save slots themselves becoming unusable, @RFKramer I’d suggest going to the wider forum about it. The beta version IME has had zero of the issues reported here (played in Firefox, normal window).

4 Likes

Quick Coding Update #4

Hello (again!)

I’ve just tried reloading the saves after clearing my cache. In the event that this still isn’t working, this announcement seems promising: New in ChoiceScript: HTML Exports, Checkpoints, and Achievements

Seemingly, I’ll be able to upload the story as an HTML download for you all to play. This file should include the ability to save progress and all other features. It looks like there won’t be the ability to have multiple save files, but this looks like the best alternative until I figure it out.

The downside would of course be that you need to download this HTML file, but it seems like the best option at the moment.

I’ll see if I can figure out the new HTML export option tomorrow and try uploading it for testing.

Best,
R.F.

7 Likes

Anyone had the game freezing? for me it happened in this scene, the problem kinda solved itself after cleanning my cache, so I just wanted to know if it was a me problem or it happened with someone else.

4 Likes

Writer’s Diary #37
November 19th, 2023

Hello all! Unfortunately, it hasn’t been a huge week for writing so far. Much of the time that I usually dedicate to writing new scenes and content has instead been spent looking through the forums and doing my own research into trying to find ways to get the previous links to work.

While I did mention an HTML download (something I can still look into if there’s interest), I figured the easiest fix would be to just create a new save entirely (link below). This is listed as an entirely new game on DashingDon, so there shouldn’t be any problems with old text files or cache problems.

Ideally, this issue won’t keep occurring, but I have attached a “v1.0” to the title of the save in the event that I need to do this in the future (you aren’t able to have two saves with the same name).

Please give this new link a try. For my Patrons, this old link should still be working as the Patreon demo is updated much more frequently. If that is not the case, please feel free to send a message and I’ll create a new save for it.

I have set aside three hours to write today, though I wanted to make this announcement first. I’ll be working on Chapter 5, the People’s Choice, focusing on your character’s potential re-election. One of the earliest scenes is a spot at Camp David, where I’m really excited to spend some time focusing on family dynamics and that element of the Presidency more.

Hopefully, this new link works properly and next week I’ll be able to announce more exciting changes than just bug fixes. As mentioned, I’ll be at my computer writing for the next few hours if there are any questions or other problems that might pop up.

EDIT: The link in Post #1 should also be updated to the new file, so feel free to click on either.

NEW Public Demo Link: https://dashingdon.com/play/rfkramer/the-peoples-house--v10/mygame/
Patreon Link: RFKramer is creating The People’s House | Patreon

13 Likes