Text not showing in index.html

What the title says; I have tried out this program for the past two days, but it’s not working out very well so far. When I want to review what I have written in index.html, the

Like the picture shows. I have to click numerous times if I wanna see what’s written, which is really odd.

EDIT: I fixed the other problem, but this lack of text/having to click to display it is still an issue unfortunately :confused:

What browser are you using to test?

I am using Firefox, as the instructions said that it was the best one for this kind of thing. I tried with Internet Explorer just to test it out, but then a little box saying “access denied” pops up.

Ok, and are your scenes plain text files saved in UTF-8?

Yes, they are plain text files, and when checking “Encoding” in Notepad++ it says that I am encoding in UTF-8 so I suppose that should be correct?

  • What are the contents of your scenes folder?
  • Do you have a startup.txt ?
  • Does your startup.txt have an *author and a *title command?
  • Can you copy and paste the code from your startup.txt here?

Yes, I’ll paste them here. Thanks for taking the time to help!

*comment Copyright 2010 by Dan Fabulich.
*comment
*comment Dan Fabulich licenses this file to you under the
*comment ChoiceScript License, Version 1.0 (the “License”); you may
*comment not use this file except in compliance with the License.
*comment You may obtain a copy of the License at
*comment
*comment http://www.choiceofgames.com/LICENSE-1.0.txt
*comment
*comment See the License for the specific language governing
*comment permissions and limitations under the License.
*comment
*comment Unless required by applicable law or agreed to in writing,
*comment software distributed under the License is distributed on an
*comment “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND,
*comment either express or implied.

*title First game evah
*author Miah
*scene_list
startup
prologue
chapter1

*create leadership 50
*create strength 50

*page_break

The skill system is there from before and not implemented into the game, I just wanted to keep them for when I start looking into that part.

The contents of my scenes folder are prologue.txt, startup.txt, chapter1.txt and choicescript_stats.txt

Can you try adding the word “test” before your *page_break just to see if you see the word “test”?

I can see it if I highlight it/mark it, like with the other text, but it does not appear on its own :confused:

Ok, then something else is wrong. You should be able to see it without highlighting it.

I tried again, and now I can see it normally, but it’s the one piece of text that shows. Nothing that comes after, or even the “next” or “stats” buttons display text unless I click several times/highlight it. Could it have to do with some order in the startup.txt maybe? I think I have everything in the right order, though…

*page_break is a command for putting a page break in-between groups of words.
So if you had…

Hello, world
*page_break
I am talking to you!

You would not see those two sentences together.
*page_break is also not the same as *finish.
The *finish command is for going to the next scene.
You can also use *goto_scene for going to a specific scene.

Try deleting the other default scenes, and creating a chapter1.txt scene
Then somewhere in your startup.txt towards the end, you can *goto_scene chapter1

About the other buttons not showing up…
You can always try downloading a fresh copy of choicescript.
You did unzip it, right?

Hmm, can we see the full code of your startup.txt?

Make sure to put the code inside the [code][/code] tag (just like how [quote][/quote] works).

I already tried downloading it again, but it was the same result; opening up and viewing the example works fine, it’s when I try to write my own choices and text that the buttons/text turn blank like that :confused:
And yes, I unzipped it.

Okay, I will post the full startup code. I’ve added some things, since I learned some other stuff in the meantime while dealing with this issue. But none of the newer added things have created this issue, just to let you know - it was there from the very beginning as soon as I started writing my own code and text.

*title Yeah
*author Miah
*scene_list
startup
nameinput
prologue
chapter1

*create name “name”
*create surname “surname”
*create fullname “fullname”

test

*page_break

Is that the full code of your startup.txt?

Huh, try adding either *finish to progress your code to the next scene (nameinput.txt) or *ending to end your code after the *page_break.

Yeah, so far. I’m still learning how to use it so I haven’t added much yet :slight_smile:

Unfortunately, that doesn’t seem to work. All that does is skipping the next scenes, taking you straight to the end of the game. It doesn’t affect the display of the text at all.

Hm, maybe I just have to accept this format for now. As long as other people don’t have the same issue playing my game, it’s okay. Maybe it’s just my computer being wierd…

Well, if your next scenes are empty, then nothing is wrong. And *ending command will also end your game prematurely.

To be frank, my head and fingers are all itchy about this :laughing:
If you don’t mind, can you post all of your code at here?

Oh no, they’re not empty! I have written some test scenes, the prologue and chapter 1 :slight_smile: Do you mean all of my scenes and stuff? Ok!

*label name
Please enter your first name.
*choice
#Input first name
*input_text name

*label surname

Please enter your surname.
*choice
#Input surname
*input_text surname

	*finish

*choice
#Turning around and run away from them
I had no idea what these… things wanted with me; the best option was definitely to try and get away as far as possible.

	I turn on my heel and sprint in the opposite direction, trying to keep my fear in check. The road before me is barely visible, and I have no idea where it will take me, but I don't have much of a choice other than to keep running.   
	
	The shadows are following, closing in on me; I could feel their presence creeping up behind. The next thing I know, the solid ground beneath my feet has vanished.
	*finish
#Getting into a fighting stance, preparing to strike
	I immediately position myself in a fighting stance, curling my hands into fists and glaring at the shadows. They seem to stop moving for a moment, almost as if they are shocked by my reaction. I take the opportunity and swing out towards one of them, my hand going right through.
	Hm. Yes, it would make sense for an immaterial being to be unaffected by physical touches. But I had to do [i]something![/i]
	
	
	But before I could get ready to try out my tactic again, or think of a new one, one of the shadows jumped at me – no, not on me; into me. I lost my balance and fell backwards, expecting to hit the ground, but finding that it had disappeared.
	Instead, I am venturing down into an endless abyss, with nothing but darkness around me.
	*finish
#Curling into a ball, screaming
	Overcome with fear, I curl into a ball on the ground, holding my hands over my head for protection and screaming at the top of my lungs.
	
	
	Get away from me, I keep repeating in my head, squeezing my eyes shut. Get away get away get away! 
	
	
	A horrible sensation suddenly runs through my body, like a shudder but so intense that it threatens to immobilize me completely. A moment later, the hard ground underneath my feet starts to vanish – [i]actually[/i] vanish – and before I know it, I am falling.
	*finish
#Reaching out towards them 
	I don't know what these shadows really are, but for some reason, they don't frighten me. 
	I study their forms and, not really knowing what good it would do, reach out a hand towards them. The shadows flicker – are they getting uneasy at my reaction? – but remain in place as my outstretched hand go right through one of them. 
	
	At that moment, they shift and move forward at such speed that I don't find time to even draw breath. For a split second, every fiber of my being tremble as if possessed, and the next thing I know the solid ground underneath my feet have disappeared. 
	I fall into the depth of nothingness, letting the darkness consume me.
	*finish

*choice
#Something’s not right here; those shadows were definitely real!
Even if it was a dream, it wasn’t just a normal dream; it couldn’t possibly be! I think, wrestling myself out of my duvet that clings to my body. Everything felt too real.
Not only the clearness of the shadows, but the ground underneath my feet, the strange sensation that came over me when they got ahold of me… It might not be entirely explainable, but I can’t just brush it off as nothing, either.
*finish
#Ugh, I must have had a glass too many last night…
“Ugh”, I mumble, struggling to get out of the duvet that I had somehow gotten tangled into.
Just how much had I had to drink last night?

	Clearly way too much if these kinds of hellish dreams found their way into my sleep. 
	
	Maybe I should consider laying off the alcohol for a week… or a lifetime.
	*finish
#Actually, this made perfect sense. It was nothing more than a silly dream, after all.
	It might have been intense, but there was hardly any more meaning to what I had just experienced than your usual dream. After all, more often than not dreams were little more than an incomprehensible mess void of any sense whatsoever. 

	I wrestled free of the duvet around I, shaking my head at what a silly display I must make.
#"Oh god, oh god, oh god, what is going on?!
	Oh god”, I breathe, heart pounding violently in my chest. “Oh god, oh god, oh god, what just happened?!”
	I struggle against the duvet holding me in place, trying but failing miserably at keeping my breathing under control. And how could I? Nothing about this situation is normal in the slightest! Normal monsters in normal dreams did not behave like those... things, and they certainly did not affect the dreamer physically, whatever it was that they did. This is all too freaky to just shake off!

Yeah, that’s my test scenes. Everything works fine otherwise, though, so I don’t think I’ve written anything wrong :open_mouth:

Hmm, aside from the fact that I can’t see the actual indentation, I don’t see any flaws structure-wise.
This is… this makes my brain tingling.

I wonder what is the cause of your error :face_with_monocle:


BTW, you said that no text shows up. But is there any choice option showed up?