Tabs, Spaces, and Macs capitalizing file names

keep getting the following error on dashing Don,

page_3 line 251: Illegal mixing of spaces and tabs; this line has a tab, but there were spaces on line 244

this is the code starting at line 244

*if minister_war = "Edward"
    *goto x

He steps forward a little, "I like Elmfoot I have a good feeling about this place hopefully i can call this home one day, I'm good with coin, farming tariffs, and livestock fees, any work really, Davie says I'm useless to him now so I'm just trying to find a place in the world if Elmfoot has space for me?"

Perhaps Edward has just fallen into a web of politics he doesn't understand either, only time will tell but he seems harmless and truly has an enthusiasm for travel

    #"sorry Edward, stay as our guest please, we can talk more when i return from the Riverlands
        *goto GGGG
    #"Raimund mentioned he needed help with the farm tarrifs, perhaps Edward could help.
        *goto GGGGG


*label GGGGG

"There is perhaps something 

There are two types of indentation. One uses spaces, one uses tabs.

I believe you’re using Cside, so what you can do is:

Hit "toggle game panel" from top right.

Hit “toggle game panel” from top right.


Make sure 'Tab Type' and 'Tab/Indent Block Size' is consistent

For example I’m using 4 spaces for indentation. That’s what I get when I hit ‘tab’ once. Yours must’ve mixed up somewhere there. After you set to what you always use, unindent those lines and reindent. That should solve your problem

EDIT: Also if you have any errors which contain lines, you would want to include the lines when you share your code.


Sorry it wouldnt copy the line numbers from cside and I’ve not worked out notepad to display them yet

The only option I can see in cside is to change all spaces to tabs or tabs to spaces

I’ve deleted the whole section 240-260 and rewritten it but I still have the same problem

I started in cside and moved to .txt as I grew more confident with code. It was working fine and I added a few lines and now it’s all a mess

I copied the whole thing back into cside and it’s fine On the cside test it runs perfect with no errors and if I compile it again it works.

But if I save the files and upload them to dashin don that’s when I get issues :confused:

Did you rename any of your files? Did you reupload your updated startup.txt alongside the new files? Dashingdon doesn’t actually delete any files - it simply replaces them if they have the same name. It’s possible that your startup.txt is pulling names for old files where the error is still present.


I created a whole new game on dashing don with the full complied scenes which all work on cside but the same error comes up :frowning:

All the other scenes work fine just the 3rd one :confused: I really don’t want to rewrite the whole thing it’s like 6k words and the formatting looks spot on but obviously there is a tab or spaces somewhere, just not on the lines where the fault is telling me

I’m not sure if you really mean compiled because what you do is only uploading the .txt files without making any changes. Maybe if they are compiled, that’s causing a problem?

I am as lost as you are, just trying to think of something different…

1 Like

I just had a lightbulb moment this morning thanks to your renaming files comment, my Mac in its infinite wisdom likes to capitalise the save game .txt file automatically, yet i had consciously ensured it was all lower case for scene moves

so although i was uploading it with the re-written section alas, still being redirected to the old one because of stupid apple qwerks!

now there are two files; one capitalized, one without, both in the folder which is confusing but its working now!

Thank you once again, i was really dreading re-writing the whole thing, and it looks like just deleting the section was enough! no idea where the tab / space was.

1 Like

Question resolved!