Spaces in alt text

First off, my apologies if the information I’m looking for is already out there somewhere, I couldn’t find it searching the forums.

My problem is, I’m making headers for my stats section and my code looks like this:

*image personalitystats.png center Your Disposition

*text_image relationshipstats.png center Your Acquaintances

(Originally I’d used *text_image both times, I just changed the first to *image to see if that made any difference… It didn’t).

But the actual alt text looks like this:


Only the text before the first space shows up. :sweat: Did I do something wrong? (I tried enclosing the text in quotes like this: *text_image relationshipstats.png center "Your Acquaintances" but it didn’t work either). Or are we just not supposed to use spaces in alt text?

1 Like

Have you checked that your image files are named and formatted properly?

They ought to be — I can get the images to show up, but the alt text is still wrong.

Can you post the problematic excerpt of your code here, if it’s possible?

The code I used for the images and the alt text is already up in the first post, I’m not sure that anything else would be relevant to this matter.

Huh, that’s weird.

I ran your code, with your image file names (different images though) in CSIDE, and I got the same results;

(don’t mind the Glados pic, it was the only thing I had available at the moment)

Using NVDA Reader, the software seems to just read the alt text “Your” and nothing else. Looks like a problem with Choicescript, if I had to guess.

That being said, you can use “YourAcquaintances” and “YourDisposition” and the software picks it up flawlessly. It doesn’t sound that much different from the spaced-out version either.

Maybe you can use that to get around this thing, since people will only hear the alt text? Sorry I couldn’t help much in this regard.

1 Like

Hmm, I might just have to make do without the spaces then. :thinking: Curiously enough, if this is a Choicescript limitation, the example given in the wiki for alt text is wrong:

That text would show up as ‘A’. :sweat_smile:

It should work with the space can you try none instead of center… just to see



1 Like

Are you using CSIDE? If so, then can you run the code without it? See if it solves the problem?

1 Like

Turns out that was it! I downloaded the lastest choicescript from github, put all my stuff into the scenes folder, and look:


Displays perfectly. :blush: Good to know that all I need to do to take care of this is compile my game manually instead of with the IDE.

(For what it’s worth, before I tried that I changed alignment to none and it didn’t seem to have any effect on the CSIDE bug).


Glad I could help. Also, you may want to report this to @CJW, since it looks like it’s a problem with CSIDE.

Good luck with your project!


Thank you @moonfungus, this was indeed a bug in CSIDE. I’ve fixed it for the next version (v1.4), sorry for the trouble!

In the meantime, as you’ve discovered, you can just compile outside of CSIDE or export as .txt files/scenes.


This topic was automatically closed 24 hours after the last reply. If you want to reopen your WiP, contact the @moderators.