Scene nightmare

#1

I have a small problem. While doing a normal run through of the game I’m working on,the scenes go a bit weird. As in, I’ll flip through the first page, through the first choice, which SHOULD lead to the next scene (i’ve tried both the scene list and goto_scene) however, when the ‘Next chapter’ button shows up, instead of taking me to the next scene I have listed, IT takes me to the default Animal scene (the, ‘Which animal are you’ from the default tutorial thing) except for the text file doesn’t exist anymore, i’ve erased it from literally everything I can, and as soon as it forces me to answer the question, it jumps to the scene its suppose to. I have no idea whats going wrong. PLs halp.

#2

Mnnn…

  1. Clear your browser cache.
  2. Check if the file is gone proper.
  3. Could yoj show the startup code?
2 Likes
#3

I’ve tried teh cache and made sure the file is completely gone. And yes ofcourse, here’s the startup code

*title Over-Analytical
*author Kesavi
*scene_list
  startup
  Day1
  Day2
  variables
  ending
  death

*create Stealth 5
*create Brutality 5
*create Wits 5
*create Speed 5
*create Fame 50
and then, just for the sake of space

But all sides pulled at him, the ringing started to pick up and his head began to pound heavily. He needed to decide...

*choice
  #Stay Hidden
    *set Stealth +5
    Jackson stayed where he was, the ringing getting worse. You grasp your head and fall back against the corner of the wall. It wasn't this bad     before. Things keep melting together, the world becomes nothing more than a swirl of colors and sounds, nothing and everything making sense.     It's too much for you to comprehend, too much for your underdeveloped brain to handle at once. You can feel a sticky liquid begin to trickle     down your cheeks and ears. As suddenly as it begin, it stops, and is replaced by what felt like an everlasting darkness. 
    

    He woke up in his bed, his mother sitting in her wicker story-time chair, his hand encased in hers. His father stares out the only  window in his bedroom with a cold expression, masking the feelings of horror and disbelief rising in him. "I'm so sorry sweetie.." his mother coos, stroking his hand lightly "We shouldn't of fought, we didn't know it would do this to you. We..." she trailed off, a few tears slipping down her cheeks as he faded back into the darkness. He felt tired, so so tired. He drifted back into a very quiet, dreamless sleep. 

    *finish

   *goto_scene Day2
  #Run to room

Is this helpful?

#4

You have *finish just before the *goto_scene Day2. Try checking if the Day1 contains exactly the same content as the old tutor’s animal scene.

Otherwise, use *page_break instead of *finish. See if any of those works.

Another thing is to double check whether you’re running the correct index.html. If you’re simply modifying the old tutorial, it should be fine. But just in case, do a hard-reload (shift + F5) to clear the cache.
If you made a duplicate of the choicescript folder, and modifying the duplicate, then you probably ran the wrong index.html. Just double check that.

3 Likes
#5

…Ah. I renamed it, deleted what I thought was all of it, and was very wrong. I see I’m awful at double checking. Thank you both for your help.

1 Like
closed #6