Randomtest Does Not End, Stuck on Seed 0

For some reason the Randomtests I run appear to have stopped working. When I run them, they are completely stuck on the starting seed and don’t do things like print an error message, or any other indicator that there is something wrong.

This is strange because prior to this, the randomtests I’ve run were completely fine. This just suddenly came out of nowhere now that my game has become a bit longer.

This is the randomtest in its cmd.exe window. As shown, it does not say “RANDOMTEST COMPLETED” or anything. It is simply blank and it stays like this forever.

This is the readnomtest-output.txt file from the image above. As shown, it is completely stuck on Seed 0

have you tried using randomtest.html instead of randomtest.cmd?
Also try the show selected choices, option to make sure its not stuck in a loop.

1 Like

You might have introduced an infinite loop somewhere?

1 Like

Yes, after some testing last night, I managed to diagnose that the issue was caused by an infinite loop. I initially dismissed the possibility at first since usually, the randomtest would report that the game went through a certain label too much when there’s an infinite loop.


This topic was automatically closed 24 hours after the last reply. If you want to reopen your WiP, contact the moderators.