Journey Into Darkness *now submitted*

Actually, I’m not seeing any difference? Perhaps I should mention that I’m using the gun in the fight with Sydney.

1 Like

Apologies indeed, let me see what I have done wrong here.
I can see my error, I have not fixed it yet and will update as soon as I have
A big thank you for your help too!

1 Like

I will like to beta test


Great - thanks Alexj you will be joining an elite group!

To play the demo, go here:

Enjoy your journey into darkness! woooooooh! :ghost:

1 Like

I believe this is the first time I’ve seen the spider path, so it was a lot of fun to go through. I also liked how you humanize all the ‘enemies’ that the MC has to face, whether it’s the Head Hunters wearing lockets of their loved ones or Lord Percival’s plant gang pleading for help, and don’t make them just flat characters.

My only complaints this time are that it seems like the red gem you get on the spider path does not do anything in the story after – it might be better if the MC doesn’t pick up the stone again. And it’s possible to go through the hints quickly due to fighting/bad ends – perhaps you can add more hints for minor things, like the boar and anaconda, or needing the neckerchief for later, or even not attacking the monkey so you can dance.


In ahead path:
“Hold on, things are going to get a bit bumpy” and you throw the anchor overboard.
Add a comma after “bumpy”.

Fortunately the Rustbucket topples back with an almighty slap that sends you all rolling around the deck.
Previously it said that Sir Malcolm and Lady Jane went into the cabins so it doesn’t seem like they should be rolling around on deck.

What follows is a dizzying ride along the Mjaa Nto As the storm drives harder and the river flows faster.
“As” should be “as”.

The Mjaa-Nta has risen appreciably and the blue waters are now frothy and brown, with flotsam and jetsam of all types floating on the surface.
Should “Mjaa-Nta” here be “Mjaa Nto”?

“You know Jill,” he says with a smile "this boat and you have a lot in common - you are tougher than you look!”
Add a comma after “smile”, change the hyphen into an em dash.

The fork to the right is faster flowing water, straight ahead and to the left look less choppy.
The left/ahead paths here seem identical… maybe add a few differences in the choices.

Use dynamite
I noticed that sometimes when using dynamite it acts as if you used all the dynamite, and in other choices (like this one right after the arrow attack), you can still use dynamite after. Is there a reason for that?

In spider path:
“So, hold onto your hats Gentlemen, this is what’s going on,” says Lady Jane.
Was playing as Jill.

"It’s a spider. A giant one. It’s…taking them,"replies Lady Jane.
Add a space between between the quotation mark and “replies”.

North West
North East
“North West” should be “Northwest”, “North East” should be “Northeast”.

Eat Provisions
Since the people only returned weapons and torches to the adventurers (and not the provisions), this choice shouldn’t be available during the spider cave. Also, it seems like if the player decides to run if they bring the mechanical spider outside then right now it doesn’t make sense why they got their provisions/equipment back either as there is no line about the MC getting their stuff back.

The feast adds 5 stamina points
Add a period after “points” – also, perhaps where previously it had “Adds 1 skill point” or “Adds 2 luck points”, etc., you could have it like this sentence where it summarizes what gave the points. I think it reads much better.

In triceratops path:
“I am going to guess we can start with Hello,” says Lady Jane and using the book she soon gets a reply from the riders.
Perhaps add single quotations around “Hello”.

In marsh:
“Yes” agrees Lady Jane. “That was like walking through treacle”.
Add a comma after “Yes”.

“Seems a shame to waste the meal” says Sir Malcolm, helping himself.
Add a comma after “meal”.

Add 2 stamina Do you want to save your progress?
Put a period after “stamina” and put a line of space before the save question.

In creature path:
The creature wades into the pool and slides beneath the surface, leaving barely a ripple .
Remove the space before the period.

“The light from space will do as bid”
Add a period after “bid”. Also, the quotation marks here are curly, so you might want to make them like the others.

In jungle:
Very carefully and slowly you walk towards the Jaguar.
Previously “jaguar” was all in lowercase, so I’d make them all the same.

“Hold him carefully as you are Jill, I know what to do.”
Add a comma after “are”.

They are waving spears and shouting the same phrase
Add a colon after “phrase”.

Currently at the end of the jungle so that’s where I’ll continue from next time.

1 Like

Excellent and many many thanks!
I will rewrite the red gem bit, I haven’t thought about this properly yet but probably along the lines of having a throw it away in disgust option and if you keep it another reason it goes away.

I will add more hints, the boar and the neckerchief are key ones so I will do that

I have updated the typos in my notepad++ but have not uploaded them to dashingdon yet

The dynamite observation is really helpful, it is because I keep forgetting to set it to false!

I will have to think about how I can make provisions go and then come back, I will probably rewrite this rather than recode it (it is easier to rewrite than recode! and saving is particularly mind-bending!)

It is bad that I misspelt mjaa nto, you may not want to know that I only recently found in the last part of the game I replaced Sir Malcolm with Lord Percival?! No idea what happened there!

Having said that, I was really pleased that I was able to create a hints system, I think this was the first time ever that I was able to show I had learned how to do anything without asking for help!

Thanks so much for your testing, I know you are testing now but I find it fascinating what paths people choose and their decisions. I think it would be really fun if games had stats on them to show this. The telltale walking dead games had this and it was strangely fascinating to me!


Edit- forgot to say I had not heard of an em dash before and googling around made me find a choicescript style guide. How I wish I had found this before I started omg :roll_eyes:

1 Like

Although it’s preferred, I don’t think you have to use them for a HG release. (The style guide is suggested for HG, but compulsory for official releases.) You can check with them if you like before you go though and change everything. If you have to change a whole lot of dashes, I suggest putting the game into notepad+++ and using the find and replace option. Shouldn’t take too long if you just hit “replace all” on each scene. (Had to do that when I decided to change a variable to something else once and it didn’t take all that long.)


I really enjoyed the doll/zombie section having played it through a few times now as it lets the player choose different ways to fight the monsters and still get the poem, adding to the game’s replayability. And I’ve said this before, but I liked the banter between the three main characters even in the middle of dangerous situations. I do think, though, that you’ll want to add hints for this temple maze and the flower ‘maze’ in the city.


“A little basic but they do the trick”
Add punctuation at the end.

“Empty already, they were tastier than I thought!” "According to Smyth-Fortesque we should be searching in the region of Mpulungu, which is only reachable by traveling down the Njaa Mto river.
After eating the provisions and receiving that “a little basic” line above, I then got this “empty already” sentence since the MC had used all the provisions. That “empty already” line doesn’t flow well from that previous sentence, especially because it is in a separate paragraph and it doesn’t say who is speaking. Also, the next sentence where Lady Jane begins to speak should be its own paragraph.

Kolf boy path:
“I hope she is at peace now” says Lady Jane.
Add a comma after “now”.

See no evil, hear no evil, speak no evil."
I would remove this quotation mark so it signals that the next sentence continues the witch doctor’s dialogue.

I can provide you with warriors, for a price." “I will provide five warriors for all your gold.”
Remove the quotation marks in between “price” and “I”.

“Excellent, excellent. Take this"
The first quotation mark is curly, unlike the others. Add punctuation after “this”.

"My boys will follow you all the while you have this pouch. When you reach the Kolf Boy you order them to attack by telling them to touye, touye, touye.
Maybe change “all the while” to “so long as”, and “you order them” to “you can order them” since the necromancer is talking about a possible future event.

Throw the doll on the fire
Perhaps “on” should be “into” here.

“Thank you for freeing us of that demon, we are in your debt. Please, take this:”
Change the colon into a period or exclamation mark.

“This is obviously where the drums and the Kolf Boy are,” he says.
Do the adventurers hear about the Kolf Boy before the witch doctor or necromancer mention it when you talk to them? Because otherwise if you fight them then there’s no chance for Sir Malcolm to hear about him, meaning he shouldn’t know who is behind the drumming in this sentence, and the MC/narration shouldn’t know either.

You shout “Touye,touye,touye” and direct the zombies to attack.
Add a space after each comma.

If you try to fight the Kolf Boy with five zombies you then get an option to confront him. Doing so causes the narration to jump right into facing the monster, but there’s none of the paragraphs that explain what the monster is or how it suddenly appeared.

It’s possible to reach the cliff with the zombies if the player fights the toad (as the toad only eats two of them), but it doesn’t seem like the zombies are ever mentioned again.

“as far from so called civilisation as he could get.”
“so called” should be “so-called”.

You make eye contact with the trembling gibbon and rub your hands,relishing sweet revenge.
Add a space after the comma.

The Jaguar Warrior has 0 stamina left The warrior falls and lies still on the ground.
Add a line of space between the battle info and the narration.

“This tablet looks important Jill” says Lady Jane, opening her notebook.
Add a comma after the MC’s name.

“Well we look like a right couple of Cnuts now!” shouts Sir Malcolm.
Should that be “nuts”?

The crowd go wild with deafening appreciation.
“go” should be “goes”.

The portcullis is North and the double doors to the East
Add a period at the end.

Says King Imperius and he places his hand on your shoulder.
“Says” should be “says”.

“Me next old girl” says Sir Malcolm.
Add a comma after “girl”.

Currently at the entrance of the city so that’s where I’ll continue from next time, although I didn’t really look at the dead ends of the maze, the tree top/flying into the city section, or what happens when you have ten zombies.

1 Like

Brilliant- thank you!
The kolf boy continuity error is a bad one :dizzy_face: It is not the worst though, that prize still belongs to the boat section where originally everyone sails from London to Zanzibar overnight!

Here is some info on “the dead ends of the maze, the tree top/flying into the city section, or what happens when you have ten zombies.”

The dead ends allow you to taunt the monkey crowd. The first time you do this you will get a stick thrown at you and this can be used to prop open the portcullis. It gives the player 2 chances as there is also the bone. The second taunt means you may get a coconut hitting your head. The tree people section is a bit heavy and it is probably the most overt example of giving some context to the enemies that you kill on the way. Basically, if you don’t climb back down you end up wiping out innocent tree dwelling families then fly to the city on a pterodactyl but you won’t have what is needed to get further. If you have ten zombies then they kill everyone at the fire ceremony, so you won’t take any damage but everyone is dead. The only way to get ten is to have the spider thingy that is in the stump, it’s luck whether you will get it or not. It gets named spot btw!

Edit - I have fixed the eat provisions error, for some reason in this one scene I didn’t use a gosub_scene. I have changed the text so it is clear the MC is speaking and I have added spaces so the text doesn’t run into whatever comes next.

Edit- I have fixed the error where you go straight int fighting the eldermonster, I had linked to the wrong label

Edit- The mystery of the disappearing zombies is now fixed (spoiler - they stay on the other side of the lake)
Edit- all the typos are corrected and uploaded now, most of the corrections have been made.
Still to do: red gem to be changed, hints to be added, continuity error with kolf boy to be fixed

“Well we look like a right couple of Cnuts now!” shouts Sir Malcolm.
Should that be “nuts”?

Here is an unbelievably long reply to that!

I live in England near a place called Bosham.

Cnut was King in the 10th Century before the battle of hastings and his daughter may be buried in the Bosham church. King Canute or Cnut famously attempted to turn back the tide of the sea .He obviously failed but he was doing it to prove he was not totally divine. So - Cnut did not turn back the tide and neither did the MC and Sir Malcolm when it was a tide of monkeys. I am afraid I am also being rude here because Cnut has similarities to a swear word. So Sir Malcolm is playing on words. I am sure you didn’t expect thsi reply!

1 Like

Well this was confusing and sorry!

I did link to the wrong win outcome from the gunfight, unhelpfully I labelled things win1, win2 and then quickly muddled them all up.

However, I can’t see how you managed to arrive here anyway because:

Sydney has 12 stamina
You have one shot
A 6 is an isntant kill but that bit was working anyway
The Most damage you can cause is therefore 5, meaning he will have 7 stamina when you fight hand to hand.
The hand to hand bit does link to the right win lable now

So, however you did it is a mystery but hats off anyway!

And thanks for finding it too

1 Like

I was able to get Spot this time around – I liked how if you go to the witch doctor she takes it from you. I enjoyed finding the antidote once again, especially as the descriptions of nature/old buildings and the solitude of the MC are a good contrast to the next section where the three of them need to work together in a scientific/futuristic setting. I was was a bit disappointed, though, that purposely wasting time and getting all the flowers doesn’t cause a bad end.


“One more thing - you had better leave that with me,” says the witchdoctor and she takes spot’s lead.
“spot” should be capitalized. Also, the section from where she hands the MC the straw doll to this line is a bit awkward to read because of the dialogue being separated into so many paragraphs using “says”. Perhaps if the MC does have Spot then the witch doctor can take him before she says good luck.

It seems like if you throw the doll into the fire you don’t get the second poem. Is that supposed to happen?

“There must be some kind of cure Jack!” says Lady Jane in desperation.
Was playing as Jill.

“It’s…too…late” he gasps. “Have…this”
Add punctuation after “late” and “this”.

Insta Win2
Was fighting the Cactus Man. Remove the “2”.

You prepare to grab the swaying rose
Add a period after “rose”.

You pull the rose off of your arm in disgust and return
This is after visiting the second crossroad’s south path (where the roses are) and failing to pick the rose. I’d put “return North” here and add a period at the end.

You return.
Same as above, except if the MC succeeds picking the rose. I’d put “You return North” here as well.

Vines entwine across the path like interlocked fingers preventing your return.
Same as above, but if you leave without attempting to pick the rose. Perhaps change this to “across the path behind you” as right now it reads as if the vines are preventing the MC from returning to the crossroads.

There is no way into the eerie building so you return.
This is after visiting the first crossroad’s northern path. I’d put “you return South”.

You refer back to the book again.
Since it’s possible for the player to pick “Look for an antidote” or “I don’t know” when Sir Malcolm is poisoned even if they have the book, having this line may be confusing as they would never have referred to the book to begin with.

“For poisoning by agents unknown, combine two parts purple lily of the valley with one part yellow flowers of the rubiaceae tree as a liquid suspension”
Add punctuation at the end.

“I don’t have any yellow flowers so I will improvise”
Add punctuation at the end.

“I am going to miss this step”
This needs punctuation at the end. Also, since all the “Nothing” options have *goto ladyjanedies right after without any space, it causes this sentence to be in the same paragraph the starts with “Jane is cradling Malcolm in her arms”, making it look like she’s the one saying it.

You look at each other aghast, then with a sudden intake of breath Malcolm sits up!
Maybe change “You look” to “You and Lady Jane look” that way it’s clearer who is looking at who, and so that Lady Jane is in the paragraph when the player reaches the line about being reunited with her and Sir Malcolm.

I noticed that the narration doesn’t describe the paths that connect the crossroads. It makes sense when the MC first enters them, since their back would be towards the exit, but you might want to add descriptions anyway since the MC would see those exits after visiting the other paths.

Dying/loading in the city section doesn’t reset the stats.

“Anything that can do that has to be useful” says Lady Jane and you take the jar.
Add a comma after “useful”.

Many shelves are on the wall of the white room,
I’d add a space after *label jarsjarsetc as this “Many shelves” paragraph blends with the option narration.

Currently at the circular stone, so that’s where I’ll continue from next time.

1 Like

many thanks for the continued help! I looked back over the code and see what you mean, if you have the poisoning book then you are forced to use the correct flowers. I will have a think about this (as I know you are collecting as many deaths as possible too!)

I am stuck at the moment on the following issues:

1- Changing the order of bet / don’t bet. This is quite complex for me so I have been thinking what to do. I am going to copy the scene, call it club2, then use a series of Goto commands. I have not done this yet.

2- Temporarily removing provisions. I don’t even have an idea for how to do this so I will be asking the forum for help in due course

3- I see the city loading section is not working. This is a nightmare come true for me and I’m afraid to even look at what I have done wrong here at the moment. I was so delighted when the save and load system worked but I knew it couldn’t be plain sailing!

This week and last week I have had no time to make any corrections but should be back on track next week.

Self pity time:
Anxiety has been creeping into this massively too, I find it quite stressful when I need to fix coding issues and I am quite disappointed in myself that I can see it is one of those things I am just not going to ever “get”.

Thank you so much for sticking with it! Your feedback has been absolutely vital for me:
You have found at least 5 game breaking errors
Your feedback on my writing has been invaluable
It has made me carry on when I wanted to give up


1 Like

The bet/just watch option switching around is a minor issue, so don’t worry too much about it. Although I don’t think you’ll need to permanently create another scene if you do change it – it looks like if you copy and paste the option (and the choices within that option) that you want to switch around it should work without more *gotos.

If you’re talking about temporarily removing provisions for the spider path, you could create a variable that works much like the saving/loading variables. So right before the group takes away everything, you *set examplevariable provisions_number, which would then allow you to set provisions to false and the amount to zero. Then, once the provisions are returned, having it as this should probably be fine:

*if (examplevariable > 0)
	*set provisions true
	*set provisions_number examplevariable

For the saving/load problem – it looks like the skill/stamina/luck variables (not the max ones) aren’t in the save or load lists.

Don’t be disappointed! The coding issues are nothing compared to how great the game is overall. :relaxed:

1 Like

Nice one- thanks!
I have corrected the typos in notepad++ but these are not uploaded to dashingdon yet

I think I have fixed the just watch/ bet so that it is consistently just watch then bet (I did this by using labels and gotos as it is easier for me to just delete them if it creates some kind of error). I will be testing this some more but seems good. I made a cut and paste club scene 2 in case I needed to go back

There is lots still to do, I have a list from this thread but from memory the biggies are
More tips for the player
Temporary remove provisions issue when you confront the big scary spider
Fix load and save
A continuity error whereby the characters impossibly know who they are about to meet
Less confusing path descriptions when collecting flowers etc

Thanks for your support, I feel more positive again today but it has been a very busy week and I am too tired to do anything clever today :sleeping:

8th December: I think the saving issue is fixed now that the skill, luck and stamina variables have been updated
I have rejigged the spider scene to eliminate the issue of temporarily removing and restoring provisions
The spider gem resurfaces later in the game In an annoying way whereby the giant spider taunts you
I have added eat provisions options to the spider scene fights as they were missing

Post cake edit: have fixed the continuity error whereby characters know about the Kolf Boy despite never hearing his name

Have added two more hints to the youdied scene

Not uploaded any changes to dashingdon yet

Taking a break now to make a coffee cake :cake:

1 Like

I have uploaded the latest changes described above to Dashingdon and will today be changing the description of adding skill and luck etc points at the start of the game - now done
In some cases items are not being added to the inventory so I will look at that next - now done
There is another hint that needs to be added - now done

Then I intend to go through all the kind feedback received to ensure I have made all the required changes - now done

I am play testing now - in the home stretch!
Have now tested the knuckle duster option and I found a few errors that are now fixed but not uploaded
testing the gun next - 23rd Dec - found a few errors with the gun, fixed now but not uploaded yet
testing gun with no ammo next - 23rd Dec- now done , testing Instant Win on every scene next

All done- all updates made as per the feedback, all testing complete!

1 Like

Here’s a few last things I saw!

“Fortunately I was able to complete my notes”
“I’ve got it!” you exclaim
“Easy!” says Sir Malcolm
“I’ve got this one!” says Lady Jane
I’d add punctuation at the end of these.

“Thirded!” adds Lady Jane A tortured moan comes from the gate.
Change “A” to “as a”.

“Be quick Jill, its nearly at the wall!”
“its” should be “it’s”.

This story is going to take some beating at the Adventures club! Cheers!”
Capitalize “club” and make the curly quotation mark at the end like the others.

You remember the envelope and open it
I think I mentioned this before, but the transition to the MC remembering the letter is a bit sudden, especially if you were able to romance Sir Malcolm or Lady Jane. Also, add punctuation at the end.

In hints:
The Victoria and Albert museum bustles
“museum” should be capitalized.

Most notable was the extreme focus of the snake on it’s prey.
“it’s” should be “its” here.

Once again I really liked how it ends on the balloon with the humor and descriptions of the river. I do think I like the abruptness of it ending with the letter more now – perhaps because I had such a great time as Jill/Jack Sinclair, and that letter certainly hints more journeys are ahead for them! :grin:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.