Image command isn't working. Am I doing it wrong?


#1

So as you already know from the title, the image command isn’t working for me for whatever reason. I’m using the command as “*image map1.JPG”. The image is saved as a jpg in the mygame file and yet whenever I test the game, the image won’t appear! There’s no error message, it’s just not there. I reset the game when I test it, and I’m testing in Firefox. The computer I’m coding on has no Internet, so I want to use solutions related to the Net as a last resort. Am I doing something wrong? Can anyone help?


#2

@Anonymoose Are you sure your placing it inside the mygame folder that has the scenes folder in it? Not any further (inside the scenes folder itself).

Secondly you must make sure the image you have is actually saved as map1. And not its original name or such. You will need to rename it if so.

Thirdly just in case be sure to change the .JPG to lowercase.

Once that is all done. Recheck.


#3

I’ve tried your suggestions and sadly, it’s still not working. But thank you for responding to this, anyways!


#4

Hmm are you able to screenshot all three? And either post or pm it. There may just be an unforeseen issue.

~ The command in the scene
~The image in the file
~The image itself with its name (renamed)

Else I can only recommend the official tutorial excerpt.


*image: This command inserts an image. Place the image in the “mygame” folder, and type the name of the image file, like this:

*image beauty.jpg
If you like, you can specify the alignment (“left” or “right”) after the image name, like this:

*image beauty.jpg left
By default, the image appears centered on a line by itself, but if you align the image left or right, the text will flow around the image. (In CSS terms, the image will “float” left or right.)


#5

Does the image have to be a certain size or format?


#6

Apologies if this is unhelpful, but you may wish to check that you included .jpg in your code. I didn’t and now have and my image which was previously being displayed in play as a file symbol now shows the image.

(likely not your issue here though. . best of luck)


#7